summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-28 22:46:29 +0200
committerJohannes Huber <johu@gentoo.org>2018-03-28 23:01:25 +0200
commit7b987bb059c77d82ef9b24b535e8a09430b9ac35 (patch)
tree202828e2af1320fe8f4218cb1aea662295840a78 /kde-plasma/kwallet-pam
parentmedia-libs/openjpeg: Fix 2.3.0 USE=static-libs compile (diff)
downloadgentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.gz
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.bz2
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.zip
kde-plasma: Version bump KDE Plasma 5.12.4
Package-Manager: Portage-2.3.26, Repoman-2.3.7
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.12.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index b3f7fada388e..0c6e610ddc3e 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.11.5.tar.xz 19060 BLAKE2B 814199f67c9026ca420c66d0dbe48ef9f1cab2d30bf3784cb3441af56ceec9ab3841dcf41021bbc5d42edffc0fc0849b714c1f279065c974bba794924fc0879c SHA512 1602ef0eeec86c653c2a99c1c514133367e7dee07d11ffbe0533066d895c71e3b7dd90187cb353446b717738600143cd09de1a5baffad5113152fd616bef90ee
DIST kwallet-pam-5.12.3.tar.xz 18584 BLAKE2B ebaa26b20d9c2f1efccdff9c129ee0982e47736b54422347e87e2dc681e8f86f2c9d2672be7f56a1358dc43a26755f1e44d38d2988357115b89ba7e35b7dac31 SHA512 04f76793e5a3e9ee8535a2dfe52cbe2477bf4ff5c06e69fa666638b85b576a51c2e899b424a4376b44737f3c35d097f3cc00adf2f66df075be952aaaad77e0da
+DIST kwallet-pam-5.12.4.tar.xz 18476 BLAKE2B 1465ebe0a7e43212f4d97db7464d7c8806e21e0f8c11071d05442bc2128c8541f624cd96abadf19d8e151604bc4caa1021d976b5074235c7d0f6be8faa15c365 SHA512 7e78dc5666238afbb8cacfe1bedd51ada19112edd52ac57943c176d288f9663f5ba41a78167f6153e6ddf29504328f5d510b5dea45e619ee702b30930e0ed9c2
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.12.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.12.4.ebuild
new file mode 100644
index 000000000000..8c9a7437fc09
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.12.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}