summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 13:53:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 14:10:32 +0100
commitcc3d9a542daf42aedb7333cd9770bfd22448db38 (patch)
tree72227eac37f4c46187f412a0bede54e517128c95 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.26.90 version bump (diff)
downloadgentoo-cc3d9a542daf42aedb7333cd9770bfd22448db38.tar.gz
gentoo-cc3d9a542daf42aedb7333cd9770bfd22448db38.tar.bz2
gentoo-cc3d9a542daf42aedb7333cd9770bfd22448db38.zip
kde-plasma/kwallet-pam: 5.26.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.26.90.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 80bbf71e2af4..1bc434eeeff7 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.25.5.tar.xz 20576 BLAKE2B b0d49d51a558ddfabb96a492822d17c64d7f569b57eefc07aa40c81df350f7bb4e3137d55d6df7a871fac676a4e5dfdffe25675b8d2c60a33a36b0115b6c9f75 SHA512 c79096903d0362a27b0607571cf2f7d949afeb9abdd04b8a9c47e79f03e5d40aa5d9f5c1ae0b4a9a55d725396930525cde71caa1c455cc43710cfbe95de4c683
DIST kwallet-pam-5.26.5.tar.xz 22808 BLAKE2B 42543b6c08dfbe873b6e2ad6503ac35b63022935ab8c40a93da432bb4d3cc240cf5da75565ef839f4cededb5c41a2a485614e47105161456f3310abcb5b79102 SHA512 bf1aeab2c4db2e0ce6e282890326b78b92ce2079f59a50d5729b0af79a7562bf845027f1f1af510181f851f7c02e4fa67c97ab58514981eca21e02ecb1ed36a3
+DIST kwallet-pam-5.26.90.tar.xz 22840 BLAKE2B 75fcf92339fcee091001fcf9555580bd2d289191f2e885d0832cde6c06b08110b6df517db3b76dd21a13081664422894cb97a2de36ab241fbc1ffb29aa92661e SHA512 e11ff363b4eca16d1dd9c5cb7d2b8afa3f2dcf19ce0d2edc616312ca9a10539706cfd6a2a3e5a653ba61b336ae0ecb51f39a2e0f37b7189858b92ef2bbab677c
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.26.90.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.26.90.ebuild
new file mode 100644
index 000000000000..7d16d41f2991
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.26.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}