summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-13 15:43:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-13 19:43:39 +0200
commit5e2d53eff8bdc42f43c5d123ca982eefdc606969 (patch)
treea758f2175a7f4e8d5be91247b3fecd0ab4616cb3 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.27.8 version bump (diff)
downloadgentoo-5e2d53eff8bdc42f43c5d123ca982eefdc606969.tar.gz
gentoo-5e2d53eff8bdc42f43c5d123ca982eefdc606969.tar.bz2
gentoo-5e2d53eff8bdc42f43c5d123ca982eefdc606969.zip
kde-plasma/kwayland-integration: 5.27.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.8.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 762930093c8e..86d206853504 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1 +1,2 @@
DIST kwayland-integration-5.27.7.tar.xz 25776 BLAKE2B 85160077fe37bd0e3799a1a8e3f9e5618e93277e7e39158590603acfa7e7cc7571b4362ebcc404a8845502a875966082b13b6100253cfb3fccf33e75e27df49f SHA512 c2dee5bc7d101582e156ebf4587f0059a109ea0e201cf12b3736e9daa41677fc57780afa6631b0f407c062c9aa6672f46fa657c28ca6617d032fc88b56cebbc9
+DIST kwayland-integration-5.27.8.tar.xz 25776 BLAKE2B 1b74edcfd390dc94b27026700bcd756a2e30eb6a6129a545df009c82ee83fd23e6a7b19439b1b9dfd919430225f306036986db35f333796ab991420c73f639a1 SHA512 f0ad69614e40b15559a172a04d3cab79fa847923d0899464e6ccafcd458fcde5ffbafee28e6f387f7f2bf838d2fa66be076d1418ff691268a2665533698126ba
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.8.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.8.ebuild
new file mode 100644
index 000000000000..f730c5fea0d6
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}