summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 12:56:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 17:21:20 +0100
commit3135a2f0741c0a72cd2c29b1e9797c28b5423f07 (patch)
tree9ff5466cb783b52c80caf45763836108b0a07e4c /kde-plasma/kwayland/kwayland-5.113.0.ebuild
parentkde-frameworks/threadweaver: 5.113.0 version bump (diff)
downloadgentoo-3135a2f0741c0a72cd2c29b1e9797c28b5423f07.tar.gz
gentoo-3135a2f0741c0a72cd2c29b1e9797c28b5423f07.tar.bz2
gentoo-3135a2f0741c0a72cd2c29b1e9797c28b5423f07.zip
kde-plasma/kwayland: 5.113.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland/kwayland-5.113.0.ebuild')
-rw-r--r--kde-plasma/kwayland/kwayland-5.113.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-plasma/kwayland/kwayland-5.113.0.ebuild b/kde-plasma/kwayland/kwayland-5.113.0.ebuild
new file mode 100644
index 000000000000..fad5ffd70de0
--- /dev/null
+++ b/kde-plasma/kwayland/kwayland-5.113.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI="true"
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.9.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+"