summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-04 13:05:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-04 16:09:07 +0100
commit71116bbbc5e88b34e5d51ee6ab39291b0d535330 (patch)
treec30ae7b00f494355cf3945de14de76375014560d /kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild
parentkde-plasma/kwrited: 5.23.5 version bump (diff)
downloadgentoo-71116bbbc5e88b34e5d51ee6ab39291b0d535330.tar.gz
gentoo-71116bbbc5e88b34e5d51ee6ab39291b0d535330.tar.bz2
gentoo-71116bbbc5e88b34e5d51ee6ab39291b0d535330.zip
kde-plasma/layer-shell-qt: 5.23.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild
new file mode 100644
index 000000000000..f33c4c5e31be
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.23.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"