summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 22:02:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:43 +0100
commit6cda367543f24356c3e396998f59d9ab0acab8d2 (patch)
tree0961dfb4cd0150bf780cbe83f6783efc850ca7cf /lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild
parentlxqt-base/lxqt-about: version bump to 0.14.1 (diff)
downloadgentoo-6cda367543f24356c3e396998f59d9ab0acab8d2.tar.gz
gentoo-6cda367543f24356c3e396998f59d9ab0acab8d2.tar.bz2
gentoo-6cda367543f24356c3e396998f59d9ab0acab8d2.zip
lxqt-base/lxqt-admin: version bump to 0.14.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild')
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild
new file mode 100644
index 000000000000..af58883a5fdd
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.6.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ kde-frameworks/kwindowsystem:5
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"