summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornic <nic@boet.cc>2022-03-30 10:55:50 -0500
committerDirkjan Ochtman <djc@gentoo.org>2022-04-07 16:12:41 +0200
commit69853414eda033b50db1931eede45b520ab1de0d (patch)
tree22fe6d6a4a8c66380306f81b24f044b5e3a5dd6b /mail-filter
parentdev-util/perf: fix bug #837086 (diff)
downloadgentoo-69853414eda033b50db1931eede45b520ab1de0d.tar.gz
gentoo-69853414eda033b50db1931eede45b520ab1de0d.tar.bz2
gentoo-69853414eda033b50db1931eede45b520ab1de0d.zip
mail-filter/postsrsd fixes initd
pass SRS_HASHLENGTH, SRS_HASHMIN, SRS_LISTEN_ADDR vars from confd into initd remove old unused init EAPI 8 the new ebuild Closes: https://bugs.gentoo.org/836390 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nic Boet <nic@boet.cc> Signed-off-by: Dirkjan Ochtman <djc@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/postsrsd/files/postsrsd.init-r2 (renamed from mail-filter/postsrsd/files/postsrsd.init)7
-rw-r--r--mail-filter/postsrsd/postsrsd-1.11-r1.ebuild35
2 files changed, 39 insertions, 3 deletions
diff --git a/mail-filter/postsrsd/files/postsrsd.init b/mail-filter/postsrsd/files/postsrsd.init-r2
index acc00232be5b..e1b21218899e 100644
--- a/mail-filter/postsrsd/files/postsrsd.init
+++ b/mail-filter/postsrsd/files/postsrsd.init-r2
@@ -1,10 +1,10 @@
#!/sbin/openrc-run
-# Copyright 2015 Gentoo Foundation
+# Copyright 2015-2022 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
PIDFILE=/var/run/$SVCNAME.pid
-SRS_DOMAIN=`postconf -h mydomain || true`
-SRS_EXCLUDE_DOMAINS=
+SRS_DOMAIN="${SRS_DOMAIN:-`postconf -h mydomain || true`}"
+SRS_EXCLUDE_DOMAINS="${SRS_EXCLUDE_DOMAINS:-''}"
depend() {
need net
@@ -18,6 +18,7 @@ start() {
-- -f "$SRS_FORWARD_PORT" -r "$SRS_REVERSE_PORT" \
-d "$SRS_DOMAIN" -s "$SRS_SECRET" -a "$SRS_SEPARATOR" \
-u "$RUN_AS" -p "$PIDFILE" -c "$CHROOT" \
+ -n "$SRS_HASHLENGTH" -N "$SRS_HASHMIN" -l "$SRS_LISTEN_ADDR" \
-D -X"$SRS_EXCLUDE_DOMAINS"
eend $?
}
diff --git a/mail-filter/postsrsd/postsrsd-1.11-r1.ebuild b/mail-filter/postsrsd/postsrsd-1.11-r1.ebuild
new file mode 100644
index 000000000000..25a52f452d8a
--- /dev/null
+++ b/mail-filter/postsrsd/postsrsd-1.11-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Postfix Sender Rewriting Scheme daemon"
+SRC_URI="https://github.com/roehling/postsrsd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/roehling/postsrsd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=">=dev-util/cmake-2.4"
+RDEPEND=""
+
+CHROOT_DIR="${EPREFIX}/var/lib/postsrsd"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCHROOT_DIR=${CHROOT_DIR}
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newinitd "${FILESDIR}/postsrsd.init-r2" postsrsd
+ newconfd "${BUILD_DIR}/postsrsd.default" postsrsd
+ keepdir ${CHROOT_DIR}
+}