summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-11 23:27:57 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:25 -0400
commitc1034c7c11b861553141a9f6f641a8b0bbc4b359 (patch)
tree2ef5741d94f424bc2e23284029d41461c09038c8 /mate-extra/mate-media/mate-media-1.12.1.ebuild
parentmate-extra/mate-screensaver: 1.12.x vbump, add gtk3, import from project repo (diff)
downloadgentoo-c1034c7c11b861553141a9f6f641a8b0bbc4b359.tar.gz
gentoo-c1034c7c11b861553141a9f6f641a8b0bbc4b359.tar.bz2
gentoo-c1034c7c11b861553141a9f6f641a8b0bbc4b359.zip
mate-extra/mate-media: 1.12.x vbump, add gtk3 support, import from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-media/mate-media-1.12.1.ebuild')
-rw-r--r--mate-extra/mate-media/mate-media-1.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/mate-extra/mate-media/mate-media-1.12.1.ebuild b/mate-extra/mate-media/mate-media-1.12.1.ebuild
new file mode 100644
index 000000000000..6097a74f0174
--- /dev/null
+++ b/mate-extra/mate-media/mate-media-1.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Multimedia related programs for the MATE desktop"
+LICENSE="LGPL-2 GPL-2 FDL-1.1"
+SLOT="0"
+
+IUSE="gtk3"
+
+RDEPEND=">=dev-libs/glib-2.36.0:2
+ dev-libs/libxml2:2
+ >=mate-base/mate-panel-1.8[gtk3(-)=]
+ >=mate-base/mate-desktop-1.9.3[gtk3(-)=]
+ >=media-libs/libmatemixer-1.9.1
+ x11-libs/cairo:0
+ x11-libs/pango:0
+ virtual/libintl:0
+ !gtk3? (
+ >=dev-libs/libunique-1:1
+ >=media-libs/libcanberra-0.13:0[gtk]
+ >=x11-libs/gtk+-2.24:2
+ )
+ gtk3? (
+ >=dev-libs/libunique-3:3
+ >=media-libs/libcanberra-0.13:0[gtk3]
+ >=x11-libs/gtk+-3.0:3
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !!<mate-base/mate-applets-1.8:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}