summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:23:32 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:15 +0300
commitd78768071fc5b20801c1bc095aa6a53d88202f0b (patch)
treec13bf16bfcc0af97242d77f237a2433d058df806 /mate-extra
parentmate-extra/mate-power-manager: drop 1.27.0 (diff)
downloadgentoo-d78768071fc5b20801c1bc095aa6a53d88202f0b.tar.gz
gentoo-d78768071fc5b20801c1bc095aa6a53d88202f0b.tar.bz2
gentoo-d78768071fc5b20801c1bc095aa6a53d88202f0b.zip
mate-extra/mate-power-manager: add 1.28.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-power-manager/Manifest1
-rw-r--r--mate-extra/mate-power-manager/mate-power-manager-1.28.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/mate-extra/mate-power-manager/Manifest b/mate-extra/mate-power-manager/Manifest
index 99b1aad4a9ea..8af314e62e68 100644
--- a/mate-extra/mate-power-manager/Manifest
+++ b/mate-extra/mate-power-manager/Manifest
@@ -1 +1,2 @@
DIST mate-power-manager-1.26.1.tar.xz 6266604 BLAKE2B 29800ffef3518722dda837a779a3e4cb639528a73091d905c5807adeac88d3b23978abf79fa7338bf2d7d5c7a75d99f99a144ff36c002b86f289a09f12a0a1fe SHA512 82bac7d32a94b3fa64c68973bd72b9a88b73d8368fc179ea0958e4b7d0021707394bc5dadaed23cc074e441ae4a753ba73ad5ba9030a276b87ac8b410a5fb37d
+DIST mate-power-manager-1.28.1.tar.xz 6724724 BLAKE2B 4181b29c68e7da79671a586520dd65fc71dbf31ff3370fe027f16bb460d534bacaefdf4289b3b0477c682870378589ae59437385875895bfb679a0dede31891a SHA512 8217fbc4a837a3632a5059d2a344788608ceda1b243b651af33482ee96ab587347bf158a9cf49e78d2a4ff4b9c9e0ee194b9f30db400649c8f56208de5a205f5
diff --git a/mate-extra/mate-power-manager/mate-power-manager-1.28.1.ebuild b/mate-extra/mate-power-manager/mate-power-manager-1.28.1.ebuild
new file mode 100644
index 000000000000..5ae48fe21e31
--- /dev/null
+++ b/mate-extra/mate-power-manager/mate-power-manager-1.28.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Session daemon for MATE that makes it easy to manage your laptop or desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+applet +elogind keyring policykit systemd test"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+# Interactive testsuite.
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=media-libs/libcanberra-0.10:0[gtk3]
+ >=sys-apps/dbus-1
+ >=sys-power/upower-0.99.8:=
+ >=x11-apps/xrandr-1.3
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.11:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ keyring? ( >=app-crypt/libsecret-0.11 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ policykit? ( >=mate-extra/mate-polkit-1.6 )
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compile-warnings=minimum \
+ $(use_with keyring libsecret) \
+ $(use_enable applet applets) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ dbus-launch Xemake check || die "Test phase failed"
+}