summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-09-15 11:55:11 +1000
committerSam James <sam@gentoo.org>2023-09-18 08:38:31 +0100
commitf291e9fa086b62e5949533da38d783ff9dd74943 (patch)
tree7ffa79112c7081e293f2cbae363a0b1884f3e0eb /media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild
parentapp-misc/elasticsearch: drop 8.7.1 (diff)
downloadgentoo-f291e9fa086b62e5949533da38d783ff9dd74943.tar.gz
gentoo-f291e9fa086b62e5949533da38d783ff9dd74943.tar.bz2
gentoo-f291e9fa086b62e5949533da38d783ff9dd74943.zip
media-fonts/intel-one-mono: new package, add 1.3.0
Upstream build this using RoboFont; a non-free macOS-only font editor. While it's theoretically possible to exactly reproduce the output of their build process using any font builder that understands the UFO (v3[?]) format, I'm unwilling to investigate and maintain a completely separate build system when other distros just install the release tarball. Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/32787 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild')
-rw-r--r--media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild b/media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild
new file mode 100644
index 000000000000..5d69d2d80dbe
--- /dev/null
+++ b/media-fonts/intel-one-mono/intel-one-mono-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FONT_SUFFIX="otf"
+
+inherit font
+
+DESCRIPTION="Intel One Mono font family"
+HOMEPAGE="https://github.com/intel/intel-one-mono"
+
+SRC_URI="https://github.com/intel/intel-one-mono/releases/download/V${PV}/otf.zip -> ${P}.zip"
+S="${WORKDIR}/otf"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="binchecks strip"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+src_compile() { :; }