summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/sil-doulos
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/sil-doulos')
-rw-r--r--media-fonts/sil-doulos/Manifest3
-rw-r--r--media-fonts/sil-doulos/metadata.xml21
-rw-r--r--media-fonts/sil-doulos/sil-doulos-4.106.ebuild27
-rw-r--r--media-fonts/sil-doulos/sil-doulos-4.110.ebuild32
-rw-r--r--media-fonts/sil-doulos/sil-doulos-5.000.ebuild24
5 files changed, 107 insertions, 0 deletions
diff --git a/media-fonts/sil-doulos/Manifest b/media-fonts/sil-doulos/Manifest
new file mode 100644
index 000000000000..b476f258ebf9
--- /dev/null
+++ b/media-fonts/sil-doulos/Manifest
@@ -0,0 +1,3 @@
+DIST DoulosSIL-4.110.zip 1498994 SHA256 8bb5701a182e9100be44dfbfc68535f2c0a5310368b25aee62280fa73194b16d
+DIST DoulosSIL4.106.zip 576928 SHA256 721a8f2e960aa3b826901854c99fdf7f10407d21d12b33630ecd58fde51697a9
+DIST sil-doulos-5.000.zip 1347526 SHA256 0b309c3db813a98ce884c0bd25c7f5c0bd96bbffd076459e39298812ca22472e SHA512 3698b3f330d34cfa2be93f9dfc87c113a0b3e174a40ce9c2277bb452161cda61aab4688338ab3aeaaaa3cc684cedc58bbb3f066392e3911246a230d1a9fb02f3 WHIRLPOOL 517ac1e81f3fe4d05ede03b1ad11af4a6ec8300165d37885dc7c80b077b7288962198b987640ec62e3cdc5405af0455c5c423ed51c764547a01a0a7f7e0a0682
diff --git a/media-fonts/sil-doulos/metadata.xml b/media-fonts/sil-doulos/metadata.xml
new file mode 100644
index 000000000000..11ebc56ba2e1
--- /dev/null
+++ b/media-fonts/sil-doulos/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+ <longdescription lang="en">
+ Welcome to the Doulos SIL font package. The goal for this product
+ was to provide a single Unicode-based font family that would
+ contain a comprehensive inventory of glyphs needed for almost any
+ Roman- or Cyrillic-based writing system, whether used for phonetic
+ or orthographic needs. In addition, there is provision for other
+ characters and symbols useful to linguists. This font makes use of
+ state-of-the-art font technologies to support complex typographic
+ issues, such as the need to position arbitrary combinations of
+ base glyphs and diacritics optimally.
+
+ Doulos is very similar to Times/Times New Roman, but only has a
+ single face - regular. It is intended for use alongside other
+ Times-like fonts where a range of styles (italic, bold) are not
+ needed.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-fonts/sil-doulos/sil-doulos-4.106.ebuild b/media-fonts/sil-doulos/sil-doulos-4.106.ebuild
new file mode 100644
index 000000000000..6b5f856acfa4
--- /dev/null
+++ b/media-fonts/sil-doulos/sil-doulos-4.106.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font
+
+DESCRIPTION="SIL Doulos - SIL font for Roman and Cyrillic Languages"
+HOMEPAGE="http://scripts.sil.org/DoulosSILfont"
+SRC_URI="mirror://gentoo/DoulosSIL${PV}.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DOCS=( OFL-FAQ.txt README.txt )
+FONT_SUFFIX="ttf"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/DoulosSIL"
+FONT_S="${S}"
+
+src_install() {
+ font_src_install
+}
diff --git a/media-fonts/sil-doulos/sil-doulos-4.110.ebuild b/media-fonts/sil-doulos/sil-doulos-4.110.ebuild
new file mode 100644
index 000000000000..b5f604e9de7d
--- /dev/null
+++ b/media-fonts/sil-doulos/sil-doulos-4.110.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit font
+
+MY_P="DoulosSIL-${PV}"
+
+DESCRIPTION="SIL Doulos - SIL font for Roman and Cyrillic Languages"
+HOMEPAGE="http://scripts.sil.org/DoulosSILfont"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+DOCS="OFL-FAQ.txt"
+FONT_SUFFIX="ttf"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}"
+
+src_install() {
+ font_src_install
+ use doc && dodoc -r "${S}"/documentation
+}
diff --git a/media-fonts/sil-doulos/sil-doulos-5.000.ebuild b/media-fonts/sil-doulos/sil-doulos-5.000.ebuild
new file mode 100644
index 000000000000..c207bc7aca1e
--- /dev/null
+++ b/media-fonts/sil-doulos/sil-doulos-5.000.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font
+
+MY_P="DoulosSIL-${PV}"
+
+DESCRIPTION="Serif font for Roman and Cyrillic languages with comprehensive orthographic support"
+HOMEPAGE="http://scripts.sil.org/DoulosSILfont"
+SRC_URI="http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=${MY_P}.zip&filename=${MY_P}.zip -> ${P}.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+DOCS="OFL-FAQ.txt documentation/*"
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}"
+FONT_SUFFIX="ttf"