summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-07-02 09:06:39 +0100
committerJustin Lecher <jlec@gentoo.org>2017-07-02 09:07:25 +0100
commit050f85c575e395a82b1029675a86739dab961946 (patch)
tree24b3d10f55ced43444d5485ddda05c103301bcf4 /media-gfx/asymptote
parentapp-misc/khal: version bump 0.9.6 bug #623396 (diff)
downloadgentoo-050f85c575e395a82b1029675a86739dab961946.tar.gz
gentoo-050f85c575e395a82b1029675a86739dab961946.tar.bz2
gentoo-050f85c575e395a82b1029675a86739dab961946.zip
media-gfx/asymptote: Bump to EAPI=6
Package-Manager: Portage-2.3.6-prefix, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'media-gfx/asymptote')
-rw-r--r--media-gfx/asymptote/asymptote-2.41.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/media-gfx/asymptote/asymptote-2.41.ebuild b/media-gfx/asymptote/asymptote-2.41.ebuild
index f48cbea6178d..b0de1fb49462 100644
--- a/media-gfx/asymptote/asymptote-2.41.ebuild
+++ b/media-gfx/asymptote/asymptote-2.41.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools elisp-common eutils latex-package multilib python-single-r1
+inherit autotools elisp-common latex-package multilib python-single-r1
DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
HOMEPAGE="http://asymptote.sourceforge.net/"
@@ -53,24 +53,27 @@ DEPEND="${RDEPEND}
TEXMF=/usr/share/texmf-site
+PATCHES=(
+ # gc.h -> gc/gc.h
+ "${FILESDIR}/${P}-configure-ac.patch"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ "${FILESDIR}/${P}-info.patch"
+)
+
pkg_setup() {
(use python || use X) && python-single-r1_pkg_setup
}
src_prepare() {
- # gc.h -> gc/gc.h
- epatch "${FILESDIR}/${P}-configure-ac.patch"
-
sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
-i configure.ac \
|| die "sed configure.ac failed"
- # Changing pdf, ps, image viewers to xdg-open
- epatch "${FILESDIR}/${P}-xdg-utils.patch"
-
- # Bug #322473
- epatch "${FILESDIR}/${P}-info.patch"
-
+ default
eautoreconf
}