summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-22 20:18:45 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-22 20:18:45 +0100
commite58c99a40fbd7dac1049684104c46e3e76951dc0 (patch)
tree203a2ac0041811d2505ba622482e2f0106917d19 /media-gfx/inkscape/inkscape-9999.ebuild
parentmusl: also mask LabOne (diff)
downloadgentoo-e58c99a40fbd7dac1049684104c46e3e76951dc0.tar.gz
gentoo-e58c99a40fbd7dac1049684104c46e3e76951dc0.tar.bz2
gentoo-e58c99a40fbd7dac1049684104c46e3e76951dc0.zip
media-gfx/inkscape: Remove useflag static-libs (now always off)
Closes: https://bugs.gentoo.org/830972 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape/inkscape-9999.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/media-gfx/inkscape/inkscape-9999.ebuild b/media-gfx/inkscape/inkscape-9999.ebuild
index 62a44f8decb6..df45f11b2dc0 100644
--- a/media-gfx/inkscape/inkscape-9999.ebuild
+++ b/media-gfx/inkscape/inkscape-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg
-openmp postscript readline spell static-libs svg2 test visio wpg"
+openmp postscript readline spell svg2 test visio wpg"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -130,7 +130,7 @@ src_configure() {
-DWITH_JEMALLOC=$(usex jemalloc)
-DENABLE_LCMS=ON
-DWITH_OPENMP=$(usex openmp)
- -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_SHARED_LIBS=ON
-DWITH_SVG2=$(usex svg2)
-DWITH_LIBVISIO=$(usex visio)
-DWITH_LIBWPG=$(usex wpg)
@@ -152,7 +152,6 @@ src_install() {
find "${ED}"/usr/share/man -type f -maxdepth 3 -name '*.gz' -exec gzip -d {} \; || die
- # No extensions are present in beta1
local extdir="${ED}"/usr/share/${PN}/extensions
if [[ -e "${extdir}" ]] && [[ -n $(find "${extdir}" -mindepth 1) ]]; then