summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-21 07:20:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-21 08:47:04 -0400
commit97020e7693287f57c91ad940c2d0238050b21714 (patch)
treea44b9ae8b2a34cb8598b1a4b833a2c6fa0fd7209 /media-gfx/xli
parentx11-wm/lwm: drop c2x workaround (diff)
downloadgentoo-97020e7693287f57c91ad940c2d0238050b21714.tar.gz
gentoo-97020e7693287f57c91ad940c2d0238050b21714.tar.bz2
gentoo-97020e7693287f57c91ad940c2d0238050b21714.zip
media-gfx/xli: improve clang16/c2x fixes
There was just one problematic line left to avoid -std=gnu89, and it may potentially have caused issues with clang16 either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/xli')
-rw-r--r--media-gfx/xli/files/xli-1.17.0-clang16.patch7
-rw-r--r--media-gfx/xli/xli-1.17.0-r6.ebuild4
2 files changed, 8 insertions, 3 deletions
diff --git a/media-gfx/xli/files/xli-1.17.0-clang16.patch b/media-gfx/xli/files/xli-1.17.0-clang16.patch
index 99a5ee44c4eb..bf60765db8b6 100644
--- a/media-gfx/xli/files/xli-1.17.0-clang16.patch
+++ b/media-gfx/xli/files/xli-1.17.0-clang16.patch
@@ -1,4 +1,11 @@
https://bugs.gentoo.org/870790
+--- a/send.c
++++ b/send.c
+@@ -37,3 +37,3 @@
+ {
+- int (*old_handler)();
++ int (*old_handler)(Display *, XErrorEvent *);
+ Pixmap pixmap;
--- a/window.c
+++ b/window.c
@@ -211,3 +211,3 @@
diff --git a/media-gfx/xli/xli-1.17.0-r6.ebuild b/media-gfx/xli/xli-1.17.0-r6.ebuild
index 573868770552..a33109d2bef3 100644
--- a/media-gfx/xli/xli-1.17.0-r6.ebuild
+++ b/media-gfx/xli/xli-1.17.0-r6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit toolchain-funcs
SNAPSHOT="2005-02-27"
DESCRIPTION="X Load Image: view images or load them to root window"
@@ -61,8 +61,6 @@ src_prepare() {
}
src_configure() {
- append-cflags -std=gnu89 # old codebase, incompatible with c2x
-
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}