summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-09 23:26:43 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-09 23:27:23 -0400
commit567a0d08d7a03820e6bbffadab84c00d4bf2c7e8 (patch)
tree4abae8ac5bff7a3df83433d14a4239fd4bc52bba /media-gfx
parentprofiles/features/wd40: Add dev-python/nh3 and revdeps (diff)
downloadgentoo-567a0d08d7a03820e6bbffadab84c00d4bf2c7e8.tar.gz
gentoo-567a0d08d7a03820e6bbffadab84c00d4bf2c7e8.tar.bz2
gentoo-567a0d08d7a03820e6bbffadab84c00d4bf2c7e8.zip
media-gfx/xdot: Migrate to PEP517 build
Closes: https://bugs.gentoo.org/909986 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xdot/xdot-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/media-gfx/xdot/xdot-9999.ebuild b/media-gfx/xdot/xdot-9999.ebuild
index 6b9cdbea7cf7..dc0e15d5f30b 100644
--- a/media-gfx/xdot/xdot-9999.ebuild
+++ b/media-gfx/xdot/xdot-9999.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
MY_PN=xdot.py
EGIT_REPO_URI="https://github.com/jrfonseca/${MY_PN}"
@@ -27,16 +26,14 @@ HOMEPAGE="https://github.com/jrfonseca/xdot.py"
LICENSE="LGPL-2+"
SLOT="0"
-RDEPEND="
+DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
media-gfx/graphviz
-"
-DEPEND="
- ${RDEPEND}
test? ( x11-libs/gtk+:3[X] )
"
+RDEPEND="${DEPEND}"
run_test() {
cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv