summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-10 22:00:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-10 22:16:58 +0200
commit609a9db8faec542616d6489af74a41e72937105b (patch)
tree7a926f42281ca0bd29b6e3c671371aabce40126d /media-gfx
parentdev-python/PyQt5: Remove old (diff)
downloadgentoo-609a9db8faec542616d6489af74a41e72937105b.tar.gz
gentoo-609a9db8faec542616d6489af74a41e72937105b.tar.bz2
gentoo-609a9db8faec542616d6489af74a41e72937105b.zip
media-gfx/fotema: New package, v1.10.0
New photo gallery app in Rust. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotema/Manifest1
-rw-r--r--media-gfx/fotema/fotema-1.10.0.ebuild85
-rw-r--r--media-gfx/fotema/metadata.xml11
3 files changed, 97 insertions, 0 deletions
diff --git a/media-gfx/fotema/Manifest b/media-gfx/fotema/Manifest
new file mode 100644
index 000000000000..1ba0293237e7
--- /dev/null
+++ b/media-gfx/fotema/Manifest
@@ -0,0 +1 @@
+DIST fotema-1.10.0.tar.xz 78681568 BLAKE2B 8956415b4e605b6c4cac12e8cd3d3179bace74ea0b5bc17bbede1d3ccc87c321cca09e6d42794c2568e2840c80333df54174d37f70368732e75657ee28d54e37 SHA512 28e1780a34f6bb655a7add708088ec4b6e42207f55055dd1011c6da9b5ea52407040cb5d02c4dff5d2ec2531ec94d02191d02ed1d29cebe64ff8a8e85f9cd0d7
diff --git a/media-gfx/fotema/fotema-1.10.0.ebuild b/media-gfx/fotema/fotema-1.10.0.ebuild
new file mode 100644
index 000000000000..2587ce67c83e
--- /dev/null
+++ b/media-gfx/fotema/fotema-1.10.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo gnome2-utils meson xdg-utils
+
+DESCRIPTION="Photo gallery for Linux"
+HOMEPAGE="https://github.com/blissd/fotema"
+SRC_URI="
+ https://github.com/blissd/fotema/releases/download/v${PV}/${P}.tar.xz
+"
+
+# see LICENSES/
+LICENSE="
+ CC-BY-2.0 CC-BY-4.0 CC-BY-NC-SA-4.0 CC-BY-SA-4.0 CC0-1.0
+ FDL-1.3+ GPL-3+ MIT
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ >=gui-libs/gtk-4.0.0:4
+"
+# indirect deps via crates
+DEPEND+="
+ dev-libs/openssl:=
+ gui-libs/libadwaita
+ media-libs/fontconfig
+ media-libs/graphene
+ media-libs/lcms:2
+ media-libs/libshumate:=
+ media-libs/opencv:=[contribdnn]
+ media-video/ffmpeg:=
+ sci-libs/onnx
+ sys-libs/libseccomp
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-libs/glib:2
+"
+
+ECARGO_VENDOR=${S}/vendor
+
+QA_FLAGS_IGNORED="/usr/bin/fotema"
+
+src_prepare() {
+ default
+ sed -i -e "/i18ndir =/s:'i18n':'share' / 'fotema' / &:" meson.build || die
+}
+
+src_configure() {
+ cat >> "${ECARGO_HOME}/config.toml" <<-EOF || die
+
+ [source."git+https://github.com/blissd/rust-faces.git?branch=patch"]
+ git = "https://github.com/blissd/rust-faces.git"
+ branch = "patch"
+ replace-with = "gentoo"
+ EOF
+
+ local emesonargs=(
+ -Dprofile=$(usex debug development default)
+ )
+
+ meson_src_configure
+ ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die
+
+ export ORT_STRATEGY=system
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
diff --git a/media-gfx/fotema/metadata.xml b/media-gfx/fotema/metadata.xml
new file mode 100644
index 000000000000..d5e5775afa5a
--- /dev/null
+++ b/media-gfx/fotema/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">blissd/fotema</remote-id>
+ </upstream>
+</pkgmetadata>