summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 02:33:57 +0000
committerSam James <sam@gentoo.org>2021-12-02 02:34:21 +0000
commit8f69aea9c3a148dcc961957e8004eaa0dc45be8b (patch)
tree00e07a69badb7322d010795bbd9a2315569d8595 /media-gfx
parentdev-util/bcc: Version bump to 0.23.0 (diff)
downloadgentoo-8f69aea9c3a148dcc961957e8004eaa0dc45be8b.tar.gz
gentoo-8f69aea9c3a148dcc961957e8004eaa0dc45be8b.tar.bz2
gentoo-8f69aea9c3a148dcc961957e8004eaa0dc45be8b.zip
media-gfx/openvdb: tweak Python detection for 9.0.0
Let's try this. We might be able to drop the options we pass in the ebuild entirely, but not wanting to mess too much for a moment. Bug: https://bugs.gentoo.org/790350 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openvdb/files/openvdb-9.0.0-unconditionally-search-Python-interpreter.patch40
-rw-r--r--media-gfx/openvdb/openvdb-9.0.0.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-9.0.0-unconditionally-search-Python-interpreter.patch b/media-gfx/openvdb/files/openvdb-9.0.0-unconditionally-search-Python-interpreter.patch
new file mode 100644
index 000000000000..66c50b485d70
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-9.0.0-unconditionally-search-Python-interpreter.patch
@@ -0,0 +1,40 @@
+From e9b193cc3481c4e157aa39e753ce49a0da69bb2b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 2 Dec 2021 02:16:15 +0000
+Subject: [PATCH] cmake: unconditionally search for Python interpreter
+
+When setting PYOPENVDB_INSTALL_DIRECTORY, CMake would fail with:
+```
+-- Could NOT find Python (missing: Python_LIBRARIES Development Development.Module Development.Embed) (found version "3.9.9")
+CMake Error at openvdb/openvdb/python/CMakeLists.txt:65 (message):
+ Could NOT find Python::Module (Required is at least version "2.7")
+Call Stack (most recent call first):
+ openvdb/openvdb/python/CMakeLists.txt:112 (openvdb_check_python_version)
+```
+
+It seems like we always need to search for the interpreter.
+
+Bug: https://bugs.gentoo.org/790350
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ openvdb/openvdb/python/CMakeLists.txt | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/openvdb/openvdb/python/CMakeLists.txt b/openvdb/openvdb/python/CMakeLists.txt
+index 2821efb5..af93976a 100644
+--- a/openvdb/openvdb/python/CMakeLists.txt
++++ b/openvdb/openvdb/python/CMakeLists.txt
+@@ -98,9 +98,7 @@ endfunction()
+ # https://github.com/AcademySoftwareFoundation/openvdb/issues/886
+ set(OPENVDB_PYTHON_DEPS)
+ set(OPENVDB_PYTHON_REQUIRED_COMPONENTS Development)
+-if(NOT DEFINED PYOPENVDB_INSTALL_DIRECTORY)
+- list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS Interpreter)
+-endif()
++list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS Interpreter)
+
+ if(USE_NUMPY)
+ list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS NumPy)
+--
+2.34.1
+
diff --git a/media-gfx/openvdb/openvdb-9.0.0.ebuild b/media-gfx/openvdb/openvdb-9.0.0.ebuild
index 898e80d496d6..60c18372ac5d 100644
--- a/media-gfx/openvdb/openvdb-9.0.0.ebuild
+++ b/media-gfx/openvdb/openvdb-9.0.0.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}/${PN}-7.1.0-0001-Fix-multilib-header-source.patch"
"${FILESDIR}/${PN}-8.1.0-glfw-libdir.patch"
"${FILESDIR}/${PN}-9.0.0-numpy.patch"
+ "${FILESDIR}/${PN}-9.0.0-unconditionally-search-Python-interpreter.patch"
)
pkg_setup() {