summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Javier Félix <web@inode64.com>2021-10-18 08:57:28 +0200
committerSam James <sam@gentoo.org>2021-10-31 03:39:32 +0000
commit647a8643d2941d4f20a6cb2b4799fc35bbc26c36 (patch)
treeea25ce1a5a1af393d382f5c40853995c1f38fc5a /media-libs/dav1d/files
parentnet-misc/stuntman: 1.2.16 (diff)
downloadgentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.gz
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.bz2
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.zip
media-libs/dav1d: fix build, support xxhash
* Require minimum nasm 2.15.05 * Disable test by default * Fix build, see bug https://code.videolan.org/videolan/dav1d/-/issues/370 and patch https://code.videolan.org/videolan/dav1d/-/commit/c6a08b3aa1ee99dade53e5e32033bc1d14455a22 the same problem with versions of gcc 10.3.0 and gcc 11.2.0, from dav1d 0.8.2 to 0.9.2. Closes: https://bugs.gentoo.org/738726 Closes: https://bugs.gentoo.org/791544 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: INODE64 <ffelix@inode64.com> Closes: https://github.com/gentoo/gentoo/pull/22621 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/dav1d/files')
-rw-r--r--media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch b/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch
new file mode 100644
index 000000000000..8a9b1e86eff9
--- /dev/null
+++ b/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch
@@ -0,0 +1,32 @@
+From c6a08b3aa1ee99dade53e5e32033bc1d14455a22 Mon Sep 17 00:00:00 2001
+From: Janne Grunau <janne-vlc@jannau.net>
+Date: Tue, 21 Sep 2021 09:30:14 +0200
+Subject: [PATCH 1/5] build: avoid meson's symbols_have_underscore_prefix
+
+Meson's dynamic check is unreliable when additional compiler flags are
+passed via CFLAGS. For example '-fprofile-instr-generate' in oss-fuzz'
+coverage build. Fixes #370.
+---
+ meson.build | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 1bf69ab..1a7c409 100644
+--- a/meson.build
++++ b/meson.build
+@@ -382,7 +382,11 @@ endif
+
+ cdata.set10('ARCH_PPC64LE', host_machine.cpu() == 'ppc64le')
+
+-if cc.symbols_have_underscore_prefix()
++# meson's cc.symbols_have_underscore_prefix() is unfortunately unrelieably
++# when additional flags like '-fprofile-instr-generate' are passed via CFLAGS
++# see following meson issue https://github.com/mesonbuild/meson/issues/5482
++if (host_machine.system() == 'darwin' or
++ (host_machine.system() == 'windows' and host_machine.cpu_family() == 'x86'))
+ cdata.set10('PREFIX', true)
+ cdata_asm.set10('PREFIX', true)
+ endif
+--
+2.32.0
+