summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2019-01-01 10:33:26 -0600
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-03 15:39:55 +0100
commit92d9ec58b92616dce6df9e08400671281a9cf8c7 (patch)
treeb0465e027d8ca84199c40a920e148df3d2a14070 /media-libs/gexiv2/gexiv2-9999.ebuild
parentgames-strategy/hedgewars: PHYSFS_SYSTEM cmake option was dropped (diff)
downloadgentoo-92d9ec58b92616dce6df9e08400671281a9cf8c7.tar.gz
gentoo-92d9ec58b92616dce6df9e08400671281a9cf8c7.tar.bz2
gentoo-92d9ec58b92616dce6df9e08400671281a9cf8c7.zip
media-libs/gexiv2: version bump to 0.10.10
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Closes: https://github.com/gentoo/gentoo/pull/10720 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/gexiv2/gexiv2-9999.ebuild')
-rw-r--r--media-libs/gexiv2/gexiv2-9999.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/media-libs/gexiv2/gexiv2-9999.ebuild b/media-libs/gexiv2/gexiv2-9999.ebuild
new file mode 100644
index 000000000000..2547c6a9ca91
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-9999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit meson python-r1 vala xdg-utils
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="gtk-doc +introspection python static-libs test vala"
+
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.38.0:2
+ >=media-gfx/exiv2-0.21:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+ test? (
+ dev-python/pygobject:3
+ media-gfx/exiv2[xmp]
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ xdg_environment_reset
+ use vala && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ # prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules
+ -Dpython2-girdir=no
+ -Dpython3-girdir=no
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+}