summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-24 06:13:33 +0000
committerSam James <sam@gentoo.org>2021-12-24 06:13:33 +0000
commit628a37720393c8362cdecfaa9686e1e873f320c5 (patch)
tree8ece128a3b1d151561b1d2a0583ac7951eb971d9 /media-libs/libaom/libaom-9999.ebuild
parentmedia-video/rav1e: silence QA flags warning for Rust (diff)
downloadgentoo-628a37720393c8362cdecfaa9686e1e873f320c5.tar.gz
gentoo-628a37720393c8362cdecfaa9686e1e873f320c5.tar.bz2
gentoo-628a37720393c8362cdecfaa9686e1e873f320c5.zip
media-libs/libaom: add 3.2.0
Bug: https://bugs.gentoo.org/816027 Bug: https://bugs.gentoo.org/828112 Bug: https://bugs.gentoo.org/793932 Bug: https://bugs.gentoo.org/798126 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libaom/libaom-9999.ebuild')
-rw-r--r--media-libs/libaom/libaom-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 358a43197c20..3d106129756e 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
inherit cmake-multilib
@@ -10,8 +10,9 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- SRC_URI="https://dev.gentoo.org/~whissi/dist/libaom/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
+ S="${WORKDIR}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
@@ -42,6 +43,7 @@ DOCS=( PATENTS )
multilib_src_configure() {
local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
-DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
-DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
-DENABLE_NASM=OFF
@@ -49,6 +51,9 @@ multilib_src_configure() {
-DENABLE_TOOLS=ON
-DENABLE_WERROR=OFF
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=OFF
+
# neon support is assumed to be always enabled on arm64
-DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
# ENABLE_DSPR2 / ENABLE_MSA for mips
@@ -62,6 +67,7 @@ multilib_src_configure() {
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
)
+
cmake_src_configure
}
@@ -69,6 +75,7 @@ multilib_src_install() {
if multilib_is_native_abi && use doc ; then
local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
+
cmake_src_install
}