summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libgig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libgig')
-rw-r--r--media-libs/libgig/Manifest2
-rw-r--r--media-libs/libgig/libgig-3.3.0.ebuild38
-rw-r--r--media-libs/libgig/libgig-4.0.0.ebuild39
-rw-r--r--media-libs/libgig/metadata.xml5
4 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/libgig/Manifest b/media-libs/libgig/Manifest
new file mode 100644
index 000000000000..d1bce3906564
--- /dev/null
+++ b/media-libs/libgig/Manifest
@@ -0,0 +1,2 @@
+DIST libgig-3.3.0.tar.bz2 338119 SHA256 d22a3c7ba13d920c1d4b6c218107ad105622ae9d1236ffbce007b98547774425
+DIST libgig-4.0.0.tar.bz2 700905 SHA256 5f4db3fbc4effe1b85dd1a2ff791fd3fc418afa6a79cd497f9de5e5c25af28f3 SHA512 171eb322a913447708881edad8da5d0d12b873bf36d191cd181dddf67a82446c8400cb4b7a6386b62ac20df8571a1597c6765fa0ef6d443957b5aae03afb345c WHIRLPOOL 1a91ed666f17b4ed12c4170fa193dead2168f9068d8b19084ec7061802fa5e73fcba2050379c3927a6ca1bcbf178baf87979d4ac94dbebdefcb1f9faccd3ab0d
diff --git a/media-libs/libgig/libgig-3.3.0.ebuild b/media-libs/libgig/libgig-3.3.0.ebuild
new file mode 100644
index 000000000000..60ead98512fe
--- /dev/null
+++ b/media-libs/libgig/libgig-3.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="a C++ library for loading Gigasampler files and DLS (Downloadable Sounds) Level 1/2 files"
+HOMEPAGE="http://www.linuxsampler.org/libgig/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc"
+
+RDEPEND=">=media-libs/libsndfile-1.0.2
+ >=media-libs/audiofile-0.2.3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf
+ emake -j1 || die "emake failed."
+
+ if use doc; then
+ emake -j1 docs || die "emake docs failed."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-libs/libgig/libgig-4.0.0.ebuild b/media-libs/libgig/libgig-4.0.0.ebuild
new file mode 100644
index 000000000000..2bce38d5f135
--- /dev/null
+++ b/media-libs/libgig/libgig-4.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="a C++ library for loading Gigasampler files and DLS (Downloadable Sounds) Level 1/2 files"
+HOMEPAGE="http://www.linuxsampler.org/libgig/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=media-libs/libsndfile-1.0.2
+ >=media-libs/audiofile-0.2.3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ emake docs
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-libs/libgig/metadata.xml b/media-libs/libgig/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-libs/libgig/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>