summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-18 12:26:23 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-18 13:09:50 -0700
commit378052578c7a89a49ecec89c8944c5f5c7190dda (patch)
tree24621b722f82a460ecb9911a6c4edd76f890361c /media-libs/libglvnd
parentmedia-libs/libglvnd: Enable Python 3 support (diff)
downloadgentoo-378052578c7a89a49ecec89c8944c5f5c7190dda.tar.gz
gentoo-378052578c7a89a49ecec89c8944c5f5c7190dda.tar.bz2
gentoo-378052578c7a89a49ecec89c8944c5f5c7190dda.zip
media-libs/libglvnd: Make X11 support optional
Closes: https://bugs.gentoo.org/693754 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libglvnd')
-rw-r--r--media-libs/libglvnd/libglvnd-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/libglvnd/libglvnd-9999.ebuild b/media-libs/libglvnd/libglvnd-9999.ebuild
index 7c3c16d23bea..be06e85ba9ad 100644
--- a/media-libs/libglvnd/libglvnd-9999.ebuild
+++ b/media-libs/libglvnd/libglvnd-9999.ebuild
@@ -25,14 +25,17 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE=""
+IUSE="X"
RDEPEND="
!media-libs/mesa[-libglvnd(-)]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- "
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ )"
DEPEND="${PYTHON_DEPS}
- ${RDEPEND}"
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
src_prepare() {
default
@@ -40,7 +43,12 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} econf
+ myconf=(
+ --disable-headers
+ $(use_enable X x11)
+ $(use_enable X glx)
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
}
multilib_src_install() {