summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-24 16:23:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-24 16:23:07 +0100
commit3d846545957fb287beb9bec7c69361878eb3a234 (patch)
treeb864a0192afd638d0d26b2f10f8e4ab704266b74 /media-libs/libilbc/libilbc-9999.ebuild
parentdev-libs/softhsm: Added botan[-bindist] dep, should fix #562804 (diff)
downloadgentoo-3d846545957fb287beb9bec7c69361878eb3a234.tar.gz
gentoo-3d846545957fb287beb9bec7c69361878eb3a234.tar.bz2
gentoo-3d846545957fb287beb9bec7c69361878eb3a234.zip
media-libs/libilbc: update to new upstream and add multilib support
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/libilbc/libilbc-9999.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/media-libs/libilbc/libilbc-9999.ebuild b/media-libs/libilbc/libilbc-9999.ebuild
index 232636092892..b056c4a0a7e1 100644
--- a/media-libs/libilbc/libilbc-9999.ebuild
+++ b/media-libs/libilbc/libilbc-9999.ebuild
@@ -2,32 +2,28 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
if [[ ${PV} == 9999 ]] ; then
SCM="autotools git-2"
- EGIT_REPO_URI="git://github.com/lu-zero/libilbc.git"
+ EGIT_REPO_URI="https://github.com/TimothyGu/libilbc"
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64"
+ SRC_URI="https://github.com/TimothyGu/libilbc/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
fi
-inherit eutils multilib ${SCM}
+inherit eutils multilib ${SCM} autotools-multilib
DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
-HOMEPAGE="https://github.com/dekkers/libilbc"
+HOMEPAGE="https://github.com/TimothyGu/libilbc"
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
[[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- find "${D}"usr/$(get_libdir) -name '*.la' -delete
+ autotools-multilib_src_prepare
}