summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-08-23 18:51:08 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-08-23 18:54:45 +0200
commit109f3017d88392afc0ceaf5216454828c007f344 (patch)
tree797e146998fc43c164f914e977dcf0327f568d18 /media-libs/libinsane/libinsane-1.0.1.ebuild
parentmedia-libs/mesa: Version bump to 19.1.5 (diff)
downloadgentoo-109f3017d88392afc0ceaf5216454828c007f344.tar.gz
gentoo-109f3017d88392afc0ceaf5216454828c007f344.tar.bz2
gentoo-109f3017d88392afc0ceaf5216454828c007f344.zip
media-libs/libinsane: initial import
New dependency for app-text/paperwork Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-libs/libinsane/libinsane-1.0.1.ebuild')
-rw-r--r--media-libs/libinsane/libinsane-1.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/libinsane/libinsane-1.0.1.ebuild b/media-libs/libinsane/libinsane-1.0.1.ebuild
new file mode 100644
index 000000000000..a2d1169ab994
--- /dev/null
+++ b/media-libs/libinsane/libinsane-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson vala
+
+DESCRIPTION="Crossplatform access to image scanners"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork/libinsane"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/libinsane/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk-doc test"
+
+RDEPEND="media-gfx/sane-backends"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-util/gtk-doc
+ )
+ test? (
+ dev-util/cunit
+ dev-util/valgrind
+ )"
+
+BDEPEND="virtual/pkgconfig
+ $(vala_depend)"
+
+# Tests require an operational valgrind
+# https://wiki.gentoo.org/wiki/Debugging
+RESTRICT="test"
+:
+PATCHES=( "${FILESDIR}"/${P}-meson_options.patch )
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc doc)
+ )
+ meson_src_configure
+}