summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmms')
-rw-r--r--media-libs/libmms/Manifest2
-rw-r--r--media-libs/libmms/libmms-0.6.2-r1.ebuild26
-rw-r--r--media-libs/libmms/libmms-0.6.2.ebuild30
-rw-r--r--media-libs/libmms/libmms-0.6.4.ebuild27
-rw-r--r--media-libs/libmms/metadata.xml12
5 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/libmms/Manifest b/media-libs/libmms/Manifest
new file mode 100644
index 000000000000..129b381cc966
--- /dev/null
+++ b/media-libs/libmms/Manifest
@@ -0,0 +1,2 @@
+DIST libmms-0.6.2.tar.gz 340230 SHA256 01931b62172d7d7050fc9ef9b1b64162f3b6e9f6cc4415170192a32a0b7ea432 SHA512 c9cf6d30488d5e925eebaec7b23fe42a58144980f64563cf01a9d05bbf25893790a7fd38f215c63650b993621e7ed8173b6ba32b179df8908bcafe66f8bf6031 WHIRLPOOL f3d34e0917d07c8a713d25c4d5bae5a46d69aad5f01909d731792f4be7c24aa52e9c40429c527cc50293c7b1c7136838d897573d9f45feebfcda853376ecf3ff
+DIST libmms-0.6.4.tar.gz 356217 SHA256 3c05e05aebcbfcc044d9e8c2d4646cd8359be39a3f0ba8ce4e72a9094bee704f SHA512 9771c697515f5232eaeaff79e68fe15e34d8aa38aa5d3d68525216357223f314c544d71b5fe18d79a77682f41b1b5d9fb5e7c3c99d0cba5723d2e3de31faec96 WHIRLPOOL c52a51868c1b4fb116c1e59b02878fb3d6300072444f90c91dc5f6bc248f77a15790ae79aafa7bb64eacc45a226496057eb9aaac213a26779624bdf8839ec5e2
diff --git a/media-libs/libmms/libmms-0.6.2-r1.ebuild b/media-libs/libmms/libmms-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..5ab70d05d83e
--- /dev/null
+++ b/media-libs/libmms/libmms-0.6.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="Common library for accessing Microsoft Media Server (MMS) media streaming protocol"
+HOMEPAGE="http://sourceforge.net/projects/libmms/ http://launchpad.net/libmms/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r8
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
diff --git a/media-libs/libmms/libmms-0.6.2.ebuild b/media-libs/libmms/libmms-0.6.2.ebuild
new file mode 100644
index 000000000000..bc816d27953e
--- /dev/null
+++ b/media-libs/libmms/libmms-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Common library for accessing Microsoft Media Server (MMS) media streaming protocol"
+HOMEPAGE="http://sourceforge.net/projects/libmms/ http://launchpad.net/libmms/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/media-libs/libmms/libmms-0.6.4.ebuild b/media-libs/libmms/libmms-0.6.4.ebuild
new file mode 100644
index 000000000000..14c3f9542c43
--- /dev/null
+++ b/media-libs/libmms/libmms-0.6.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="Common library for accessing Microsoft Media Server (MMS) media streaming protocol"
+HOMEPAGE="http://sourceforge.net/projects/libmms/ http://launchpad.net/libmms/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-medialibs-20130224-r8
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
diff --git a/media-libs/libmms/metadata.xml b/media-libs/libmms/metadata.xml
new file mode 100644
index 000000000000..5ed47c256631
--- /dev/null
+++ b/media-libs/libmms/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libmms</remote-id>
+ <remote-id type="launchpad">libmms</remote-id>
+ </upstream>
+</pkgmetadata>