summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-11-04 06:51:48 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-10-15 17:09:02 +0100
commit4c8a5f8499c8f8ee869dd9d7a1ba7858926ad3a3 (patch)
tree66b197f7e9152780f210ba7baa271d8469833072 /media-libs/libsdl2
parentdev-python/bpython: bump to 0.20 (diff)
downloadgentoo-4c8a5f8499c8f8ee869dd9d7a1ba7858926ad3a3.tar.gz
gentoo-4c8a5f8499c8f8ee869dd9d7a1ba7858926ad3a3.tar.bz2
gentoo-4c8a5f8499c8f8ee869dd9d7a1ba7858926ad3a3.zip
media-libs/libsdl2: Support app-i18n/fcitx and app-i18n/ibus.
Closes: https://bugs.gentoo.org/670248 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.12-r2.ebuild16
-rw-r--r--media-libs/libsdl2/metadata.xml2
2 files changed, 15 insertions, 3 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.12-r2.ebuild b/media-libs/libsdl2/libsdl2-2.0.12-r2.ebuild
index e550c24802d3..83131e2c099f 100644
--- a/media-libs/libsdl2/libsdl2-2.0.12-r2.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.12-r2.ebuild
@@ -13,10 +13,12 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~ppc ~ppc64 sparc x86"
-IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus gles2 haptic jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus fcitx4 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
+ fcitx4? ( dbus )
gles2? ( video )
+ ibus? ( dbus )
jack? ( sound )
nas? ( sound )
opengl? ( video )
@@ -29,7 +31,9 @@ REQUIRED_USE="
CDEPEND="
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ fcitx4? ( app-i18n/fcitx:4 )
gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ ibus? ( app-i18n/ibus )
jack? ( virtual/jack[${MULTILIB_USEDEP}] )
kms? (
>=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
@@ -65,6 +69,7 @@ CDEPEND="
RDEPEND="${CDEPEND}
vulkan? ( media-libs/vulkan-loader )"
DEPEND="${CDEPEND}
+ ibus? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
vulkan? ( dev-util/vulkan-headers )
X? ( x11-base/xorg-proto )
"
@@ -92,7 +97,7 @@ src_prepare() {
# Unbundle some headers.
rm -r src/video/khronos || die
- ln -s "${SYSROOT}${EPREFIX}"/usr/include src/video/khronos || die
+ ln -s "${ESYSROOT}/usr/include" src/video/khronos || die
AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
}
@@ -100,6 +105,10 @@ src_prepare() {
multilib_src_configure() {
use custom-cflags || strip-flags
+ if use ibus; then
+ local -x IBUS_CFLAGS="-I${ESYSROOT}/usr/include/ibus-1.0 -I${ESYSROOT}/usr/include/glib-2.0 -I${ESYSROOT}/usr/$(get_libdir)/glib-2.0/include"
+ fi
+
# sorted by `./configure --help`
local myeconfargs=(
$(use_enable static-libs static)
@@ -166,7 +175,8 @@ multilib_src_configure() {
$(use_enable vulkan video-vulkan)
$(use_enable udev libudev)
$(use_enable dbus)
- --disable-ibus
+ $(use_enable fcitx4 fcitx)
+ $(use_enable ibus)
$(use_enable tslib input-tslib)
--disable-directx
--disable-rpath
diff --git a/media-libs/libsdl2/metadata.xml b/media-libs/libsdl2/metadata.xml
index ec21c0415ca4..fb417beddc0a 100644
--- a/media-libs/libsdl2/metadata.xml
+++ b/media-libs/libsdl2/metadata.xml
@@ -24,8 +24,10 @@
Perl, PHP, Pike, Python, and Ruby.
</longdescription>
<use>
+ <flag name="fcitx4">Enable support for <pkg>app-i18n/fcitx</pkg> 4</flag>
<flag name="gles2">include OpenGL ES 2.0 support</flag>
<flag name="haptic">Enable the haptic (force feedback) subsystem</flag>
+ <flag name="ibus">Enable support for <pkg>app-i18n/ibus</pkg></flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
<flag name="kms">Build the KMSDRM video driver</flag>
<flag name="sound">Control audio support (disable at your own risk)</flag>