summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-11-14 07:50:37 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-11-14 07:50:49 +0100
commit0eee8748342078e64003e25f2b89c9670f606f71 (patch)
tree64f31fb8b32575bcb41c31fe4a6df94f13efb25c /media-libs/libsoundtouch
parentdev-ruby/rotp: add 6.2.1 (diff)
downloadgentoo-0eee8748342078e64003e25f2b89c9670f606f71.tar.gz
gentoo-0eee8748342078e64003e25f2b89c9670f606f71.tar.bz2
gentoo-0eee8748342078e64003e25f2b89c9670f606f71.zip
media-libs/libsoundtouch: bump to 2.3.2
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/Manifest1
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/Manifest b/media-libs/libsoundtouch/Manifest
index 76ff18b66267..8b17e65c2ae7 100644
--- a/media-libs/libsoundtouch/Manifest
+++ b/media-libs/libsoundtouch/Manifest
@@ -1 +1,2 @@
DIST soundtouch-2.3.1.tar.bz2 529126 BLAKE2B f8ba587ac199cd1e91f3d3487b81457b7c7bb2b4dca8867376ae47f92bf4d5e60aef3d310eab56510995d5ce72e94ce55ecc4e601bfb3b4eba52c40982032d6b SHA512 9fac7484aead1a20aae019b29847ea13ad6d8cb72272313fcffd859b31479d2ab2fe2f69cfef2b3fd35e9b03923d095bf44a67b46f2b313ac711aa31df0fdd59
+DIST soundtouch-2.3.2.tar.gz 583373 BLAKE2B cd3c8fffaa81a2ed867f5a564dd7ff3047b4de576536c3c116162981261bf3789d16def1c94e5be2450373be3f61fd67fa44e3552e19cad7b7d5d56500b98255 SHA512 72cd38f3e11f3c55ff7ed3691fd9a749a5f8d072e08ed03f2fd43a8664962138afaf3e4647116940e86f6ae374a1ba3bcd4b108280da29f3ffa6091cf383ea35
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
new file mode 100644
index 000000000000..0b26840141e7
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://www.surina.net/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}