summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-04 11:18:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-04 11:21:17 +0200
commit8c677a9aec5600b802458ad33825d4510f21f2e0 (patch)
tree44fdfeb017962cc40e7e730ac9d2826301b3a42e /media-libs/oneVPL-intel-gpu
parentsci-libs/caffe2: add 2.2.2 (diff)
downloadgentoo-8c677a9aec5600b802458ad33825d4510f21f2e0.tar.gz
gentoo-8c677a9aec5600b802458ad33825d4510f21f2e0.tar.bz2
gentoo-8c677a9aec5600b802458ad33825d4510f21f2e0.zip
media-libs/oneVPL-intel-gpu: add 24.2.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/oneVPL-intel-gpu')
-rw-r--r--media-libs/oneVPL-intel-gpu/Manifest1
-rw-r--r--media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-24.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/oneVPL-intel-gpu/Manifest b/media-libs/oneVPL-intel-gpu/Manifest
index 7956e008e275..747ddca464a1 100644
--- a/media-libs/oneVPL-intel-gpu/Manifest
+++ b/media-libs/oneVPL-intel-gpu/Manifest
@@ -1,2 +1,3 @@
DIST oneVPL-intel-gpu-24.1.3.tar.gz 9055096 BLAKE2B 63f4b14660ef897f9b67675f7b54bd0f48097570d69cc9206e7cc21476854537df5e0c925de413dc6267ab08ca59a3b72a08070b0a0652baa9a7c02f1976a98c SHA512 d885e1076fafa82da5433d38c729b3a5016a8b39f30511c8eff2f695d53ef6d7835b366db8c9cb6d1bd5f30ce47ea84e1a31fb85a536daef0a0c4cd6a874c37d
DIST oneVPL-intel-gpu-24.1.4.tar.gz 9055058 BLAKE2B 28c4b05dcaa2f2ce460b6a0d058c48253b891e1a1893cb7b0b883e01638c44c9987357e2671e7077155863b7a3763e18f46039f908abcd19aff859c3bc2fc2a4 SHA512 20e26a89965181fff89a4722a0fe069ff8356cbe719c753ac32864d046234b601b22fc8df28b0575f147d173888d3218baf218f1a0bab89e1fe7d8a0e2c1e0b4
+DIST oneVPL-intel-gpu-24.2.0.tar.gz 9057738 BLAKE2B a878ff81f30ce9278b249fb7c3fc19b8c3165a6255413c0844d1cc01947f0cd53c87227a885103a9a7ce218d531d2a8f5d3987b40ebd005088b48545aa67d6cf SHA512 a5c7bd65a4c4c2625448bab4a7ee96ff550ee7f5f1e8f00a84177022a6b806ab6f224c6295f8f3cc7548769ae75b03fea7713c757718424548f1ad365f1df6b7
diff --git a/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-24.2.0.ebuild b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-24.2.0.ebuild
new file mode 100644
index 000000000000..267fd4dabc9c
--- /dev/null
+++ b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-24.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="oneAPI Video Processing Library Intel GPU implementation"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL-intel-gpu"
+SRC_URI="https://github.com/oneapi-src/oneVPL-intel-gpu/archive/refs/tags/intel-onevpl-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-onevpl-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/libva
+ x11-libs/libdrm[video_cards_intel]
+"
+# At runtime we need a dispatcher, libvpl is preferred but mediasdk also works
+RDEPEND="${DEPEND}
+ >=media-libs/libva-intel-media-driver-${PV}
+ || (
+ media-libs/libvpl[drm,vaapi]
+ media-libs/intel-mediasdk
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_RUNTIME=ON
+ # To build the kernels we need to package the cm-compiler, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_TESTS="$(usex test)"
+ # This only seems to do something if we BUILD_KERNELS=ON
+ #-DBUILD_TOOLS="$(usex tools)"
+ # OpenCL only has an effect if we build kernels
+ -DENABLE_OPENCL=OFF
+ )
+ cmake_src_configure
+}