summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-03 22:04:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-03 22:30:52 +0100
commit6c8b95f0ffa4570543e8c10e594584db64e1541a (patch)
tree8a7bfa7a97ead7a18daa7609df2fc789a4e4bcff /media-libs/openjpeg/files
parentdev-tcltk/tkimg: reduce size of filesdir (diff)
downloadgentoo-6c8b95f0ffa4570543e8c10e594584db64e1541a.tar.gz
gentoo-6c8b95f0ffa4570543e8c10e594584db64e1541a.tar.bz2
gentoo-6c8b95f0ffa4570543e8c10e594584db64e1541a.zip
media-libs/openjpeg: Fix USE static-libs
Bug: https://bugs.gentoo.org/634144 Bug: https://bugs.gentoo.org/650322 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/openjpeg/files')
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.3.0-fix-disable-static-libs.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/openjpeg/files/openjpeg-2.3.0-fix-disable-static-libs.patch b/media-libs/openjpeg/files/openjpeg-2.3.0-fix-disable-static-libs.patch
new file mode 100644
index 000000000000..9e30f4694f3e
--- /dev/null
+++ b/media-libs/openjpeg/files/openjpeg-2.3.0-fix-disable-static-libs.patch
@@ -0,0 +1,23 @@
+From 66297f07a43d2770a97c8456d20202f3d051d980 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Mon, 9 Oct 2017 11:40:43 +0200
+Subject: [PATCH] Unix build: fix regression of 2.3.0 where a shared-only or
+ static-only build lacks the installation target for the library (#1019, fixes
+ regression introduced by 3dfc6ca2bcf06fd1adb6b6b4cecc6c092f08ba0b)
+
+---
+ src/lib/openjp2/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/lib/openjp2/CMakeLists.txt b/src/lib/openjp2/CMakeLists.txt
+index 0b4520384..f8990ccf0 100644
+--- a/src/lib/openjp2/CMakeLists.txt
++++ b/src/lib/openjp2/CMakeLists.txt
+@@ -99,6 +99,7 @@ else()
+ set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME} openjp2_static)
+ else()
+ add_library(${OPENJPEG_LIBRARY_NAME} ${OPENJPEG_SRCS})
++ set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME})
+ endif()
+ endif()
+