summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Smith <smith.dustin2017@gmail.com>2022-04-21 22:22:08 -0400
committerSam James <sam@gentoo.org>2022-04-23 02:20:05 +0100
commitb81fb8d368376faefc0d71a15c44d1cfd9d8dab1 (patch)
tree6fdff9e64b0d72ca681a93ce98b22b841aac6545 /media-libs/opus/opus-1.3.1-r3.ebuild
parentx11-plugins/gkrellm-cpupower: fix recursive variable CC (diff)
downloadgentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.tar.gz
gentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.tar.bz2
gentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.zip
media-libs/opus: fix word split issue in ebuild
shellbugbot points out an issue with shellcheck where $INTRINSIC_FLAGS won't be split on space because of the double quoting. If I am reading the ebuild correctly, then "use" is receiving one big argument "cpu_flags_x86_sse cpu_flags_arm_neon" in just one iteration. This commit just removes the double quotes to fix this. Bug: https://bugs.gentoo.org/839222 Closes: https://github.com/gentoo/gentoo/pull/25147 Signed-off-by: Dustin Smith <smith.dustin2017@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/opus/opus-1.3.1-r3.ebuild')
-rw-r--r--media-libs/opus/opus-1.3.1-r3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/opus/opus-1.3.1-r3.ebuild b/media-libs/opus/opus-1.3.1-r3.ebuild
new file mode 100644
index 000000000000..e250256c7441
--- /dev/null
+++ b/media-libs/opus/opus-1.3.1-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal
+
+DESCRIPTION="Open codec for interactive speech and music transmission over the Internet"
+HOMEPAGE="https://opus-codec.org/"
+SRC_URI="https://archive.mozilla.org/pub/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86"
+INTRINSIC_FLAGS="cpu_flags_x86_sse cpu_flags_arm_neon"
+IUSE="custom-modes doc static-libs ${INTRINSIC_FLAGS}"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.1-libdir-macro.patch
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable doc)
+ $(use_enable static-libs static)
+ )
+
+ local i
+ # We want to disable intrinsics if no flags are enabled
+ # (This is a fun Bash construct to do that!)
+ # bug #752069
+ for i in ${INTRINSIC_FLAGS} ; do
+ use ${i} && myeconfargs+=( --enable-intrinsics ) && break
+ done || myeconfargs+=( --disable-intrinsics )
+
+ if is-flagq -ffast-math || is-flagq -Ofast; then
+ myeconfargs+=( --enable-float-approx )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}