summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /media-libs/x265
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/x265-2.8.ebuild3
-rw-r--r--media-libs/x265/x265-2.9.ebuild3
-rw-r--r--media-libs/x265/x265-3.0.ebuild1
-rw-r--r--media-libs/x265/x265-3.1.2.ebuild1
-rw-r--r--media-libs/x265/x265-3.1.ebuild1
-rw-r--r--media-libs/x265/x265-3.2.ebuild1
-rw-r--r--media-libs/x265/x265-9999.ebuild1
7 files changed, 9 insertions, 2 deletions
diff --git a/media-libs/x265/x265-2.8.ebuild b/media-libs/x265/x265-2.8.ebuild
index c60b19162d5f..6bd37642a5be 100644
--- a/media-libs/x265/x265-2.8.ebuild
+++ b/media-libs/x265/x265-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/160"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-2.9.ebuild b/media-libs/x265/x265-2.9.ebuild
index 38316ce55ea2..5f28b491babf 100644
--- a/media-libs/x265/x265-2.9.ebuild
+++ b/media-libs/x265/x265-2.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/165"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-3.0.ebuild b/media-libs/x265/x265-3.0.ebuild
index d2632fb2a57a..2d1942d399d2 100644
--- a/media-libs/x265/x265-3.0.ebuild
+++ b/media-libs/x265/x265-3.0.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/169"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-3.1.2.ebuild b/media-libs/x265/x265-3.1.2.ebuild
index 599c13412516..71303686d68a 100644
--- a/media-libs/x265/x265-3.1.2.ebuild
+++ b/media-libs/x265/x265-3.1.2.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/176"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-3.1.ebuild b/media-libs/x265/x265-3.1.ebuild
index 599c13412516..71303686d68a 100644
--- a/media-libs/x265/x265-3.1.ebuild
+++ b/media-libs/x265/x265-3.1.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/176"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-3.2.ebuild b/media-libs/x265/x265-3.2.ebuild
index a020423d9d59..b1d719a14b6c 100644
--- a/media-libs/x265/x265-3.2.ebuild
+++ b/media-libs/x265/x265-3.2.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/179"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index e946da2c3db5..d5d064525690 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/180"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"