summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:22:11 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:24:29 +0100
commit78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085 (patch)
tree682ddacec40f41180a95055f293756e71c3fbd61 /media-libs
parentsys-apps/fakeroot: stable 1.22 for sparc, bug #635850 (thanks to Rolf Eike Beer) (diff)
downloadgentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.tar.gz
gentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.tar.bz2
gentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.zip
*/*: revert https://github.com/gentoo/gentoo/pull/5828.
This commit adds back the string of commits from PR 5828.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/files/cogl-1.22.0-initial-output.patch46
-rw-r--r--media-libs/cogl/files/cogl-1.22.0-wait-flip.patch42
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
3 files changed, 135 insertions, 0 deletions
diff --git a/media-libs/cogl/files/cogl-1.22.0-initial-output.patch b/media-libs/cogl/files/cogl-1.22.0-initial-output.patch
new file mode 100644
index 000000000000..d7f9d0ff99f4
--- /dev/null
+++ b/media-libs/cogl/files/cogl-1.22.0-initial-output.patch
@@ -0,0 +1,46 @@
+From 188752158701e3a406e7fd5850b3eaf9c4798cd7 Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Fri, 13 Nov 2015 13:35:05 -0500
+Subject: winsys-egl-kms: bypass initial output setup if kms fd passed in
+
+if mutter is handling the output setup, then we shouldn't do it,
+too.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=758073
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 12 ++++++++----
+ 1 file changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index b460907..6d7049d 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -663,6 +663,14 @@ _cogl_winsys_egl_display_setup (CoglDisplay *display,
+ return FALSE;
+ }
+
++ /* Force a full modeset / drmModeSetCrtc on
++ * the first swap buffers call.
++ */
++ kms_display->pending_set_crtc = TRUE;
++
++ if (kms_renderer->opened_fd < 0)
++ return TRUE;
++
+ output0 = find_output (0,
+ kms_renderer->fd,
+ resources,
+@@ -736,10 +744,6 @@ _cogl_winsys_egl_display_setup (CoglDisplay *display,
+ kms_display->width = output0->mode.hdisplay;
+ kms_display->height = output0->mode.vdisplay;
+
+- /* We defer setting the crtc modes until the first swap_buffers request of a
+- * CoglOnscreen framebuffer. */
+- kms_display->pending_set_crtc = TRUE;
+-
+ return TRUE;
+ }
+
+--
+cgit v0.11.2
+
diff --git a/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch b/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch
new file mode 100644
index 000000000000..b7c4d99a2812
--- /dev/null
+++ b/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch
@@ -0,0 +1,42 @@
+From a583492ea2aa3ea8e78c269bd5db3f52f82aa79c Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Wed, 21 Oct 2015 15:47:01 -0400
+Subject: kms-winsys: don't wait for a flip when page flipping fails
+
+If we get EACCES from drmPageFlip we're not going to get
+a flip event and shouldn't wait for one.
+
+This commit changes the EACCES path to silently ignore the
+failed flip request and just clean up the fb.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=756926
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index 20c325c..b460907 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -590,7 +590,7 @@ flip_all_crtcs (CoglDisplay *display, CoglFlipKMS *flip, int fb_id)
+ for (l = kms_display->crtcs; l; l = l->next)
+ {
+ CoglKmsCrtc *crtc = l->data;
+- int ret;
++ int ret = 0;
+
+ if (crtc->count == 0 || crtc->ignore)
+ continue;
+@@ -610,7 +610,8 @@ flip_all_crtcs (CoglDisplay *display, CoglFlipKMS *flip, int fb_id)
+ }
+ }
+
+- flip->pending++;
++ if (ret == 0)
++ flip->pending++;
+ }
+
+ if (kms_renderer->page_flips_not_supported && needs_flip)
+--
+cgit v0.11.2
+
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
new file mode 100644
index 000000000000..ecf9de908cfd
--- /dev/null
+++ b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
@@ -0,0 +1,47 @@
+Solves automagic selection of Qt version.
+
+https://bugs.gentoo.org/show_bug.cgi?id=523122
+https://bugzilla.gnome.org/show_bug.cgi?id=737174
+
+diff --git a/configure.ac b/configure.ac
+index e9ead09..3ee710a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
+ AS_HELP_STRING([--enable-qt],
+ [enable Qt support, (MP3 album art) [[default=auto]]]),,
+ [enable_qt=auto])
++AC_ARG_WITH(qt-version,
++ AS_HELP_STRING([--with-qt-version=major],
++ [Force specific Qt version [[default=auto]]]),,
++ [with_qt_version=auto])
+
+ selected_for_media_art="no (disabled)"
+
+@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
+ fi
+
+ if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
+- PKG_CHECK_MODULES(QT5,
+- [Qt5Gui >= $QT5_REQUIRED],
+- [have_qt5=yes],
+- [have_qt5=no])
+- PKG_CHECK_MODULES(QT4,
+- [QtGui >= $QT4_REQUIRED],
+- [have_qt4=yes],
+- [have_qt4=no])
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
++ PKG_CHECK_MODULES(QT5,
++ [Qt5Gui >= $QT5_REQUIRED],
++ [have_qt5=yes],
++ [have_qt5=no])
++ fi
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
++ PKG_CHECK_MODULES(QT4,
++ [QtGui >= $QT4_REQUIRED],
++ [have_qt4=yes],
++ [have_qt4=no])
++ fi
+
+ if test "x$have_qt5" = "xyes"; then
+ BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"