summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-10-02 09:47:14 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-10-02 09:47:14 +0200
commitd31ee71612d06f7c96f297a71124c42728702b2f (patch)
tree25f638bf4a4ee2274ed5a16098b1c401c8e83198 /media-libs
parentmedia-libs/lv2: bump to 1.18.10 (diff)
downloadgentoo-d31ee71612d06f7c96f297a71124c42728702b2f.tar.gz
gentoo-d31ee71612d06f7c96f297a71124c42728702b2f.tar.bz2
gentoo-d31ee71612d06f7c96f297a71124c42728702b2f.zip
media-libs/ganv: bump to 1.8.2 + updated homepage
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ganv/Manifest1
-rw-r--r--media-libs/ganv/files/ganv-1.8.2-make-intl-check-non-required.patch13
-rw-r--r--media-libs/ganv/ganv-1.8.0-r1.ebuild2
-rw-r--r--media-libs/ganv/ganv-1.8.2.ebuild45
4 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/ganv/Manifest b/media-libs/ganv/Manifest
index f4a4f47e8408..58024540f117 100644
--- a/media-libs/ganv/Manifest
+++ b/media-libs/ganv/Manifest
@@ -1 +1,2 @@
DIST ganv-1.8.0.tar.bz2 382822 BLAKE2B 4936b7f87fa7cf17ed86b8165558684f0f59387c9673144d57d8505e41f367735117e9f5b08508dcecb831b77b6bbc6559323417824a9f8defc43c81cc91d469 SHA512 00969879592af11d211ad790b970a8a3765ec0591515af856230e3fc9371b1611f2a4edc73d1fc59371a4c4a49c7479f279dc6f298d843296e6707cd2d495af4
+DIST ganv-1.8.2.tar.xz 80496 BLAKE2B 45e5370f3b94a7010f89943225748e40291583f7d2cc80f637f3db4fac3a03c9b58217bd8e8119f7867302c43846be47e928721addce68560c63cec5faa3b4d4 SHA512 12544d45fc3b06a02dcfaf41be266770a8dcbd079979b07cb1a05388e3cdddd54040b609f76c16c8982d89f864e5000d04fd2d09d8036705a41cafe944c2a6dd
diff --git a/media-libs/ganv/files/ganv-1.8.2-make-intl-check-non-required.patch b/media-libs/ganv/files/ganv-1.8.2-make-intl-check-non-required.patch
new file mode 100644
index 000000000000..ff89e795ed2a
--- /dev/null
+++ b/media-libs/ganv/files/ganv-1.8.2-make-intl-check-non-required.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index 27cb852..eb3500c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -45,7 +45,7 @@ endif
+
+ m_dep = cc.find_library('m', required: false)
+
+-intl_dep = cc.find_library('intl', required: get_option('nls'))
++intl_dep = cc.find_library('intl', required: get_option('nls'), required: false)
+
+ gtk2_dep = dependency('gtk+-2.0',
+ version: '>= 2.10.0',
diff --git a/media-libs/ganv/ganv-1.8.0-r1.ebuild b/media-libs/ganv/ganv-1.8.0-r1.ebuild
index 6ed5c20f508f..a9a355b53a80 100644
--- a/media-libs/ganv/ganv-1.8.0-r1.ebuild
+++ b/media-libs/ganv/ganv-1.8.0-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_REQ_USE='threads(+)'
inherit flag-o-matic waf-utils python-any-r1
DESCRIPTION="A GTK+ widget for interactive graph-like environments"
-HOMEPAGE="http://drobilla.net/software/ganv/"
+HOMEPAGE="https://drobilla.net/software/ganv.html"
SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
LICENSE="GPL-3+"
diff --git a/media-libs/ganv/ganv-1.8.2.ebuild b/media-libs/ganv/ganv-1.8.2.ebuild
new file mode 100644
index 000000000000..18d6205e1dbc
--- /dev/null
+++ b/media-libs/ganv/ganv-1.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A GTK+ widget for interactive graph-like environments"
+HOMEPAGE="https://drobilla.net/software/ganv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fdgl +graphviz introspection nls"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2
+ graphviz? ( media-gfx/graphviz[gtk2] )
+ introspection? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection:=[doctool]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ nls? ( virtual/libintl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.2-make-intl-check-non-required.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature fdgl)
+ $(meson_feature graphviz)
+ $(meson_feature introspection gir)
+ $(meson_feature nls)
+ )
+
+ meson_src_configure
+}