summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-05-30 11:42:23 -0400
committerDavid Seifert <soap@gentoo.org>2017-05-31 08:40:48 +0200
commit3f15c8ebdfa9cb3b5965f4783f6a4889ff93e978 (patch)
treeb826bb8df0fe3428365c26158a835be0dafb049a /media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild
parentmedia-plugins/kodi-pvr-njoy: Fix 2.4.3 manifest (diff)
downloadgentoo-3f15c8ebdfa9cb3b5965f4783f6a4889ff93e978.tar.gz
gentoo-3f15c8ebdfa9cb3b5965f4783f6a4889ff93e978.tar.bz2
gentoo-3f15c8ebdfa9cb3b5965f4783f6a4889ff93e978.zip
media-plugins/kodi-vfs-rar: RAR VFS addon for Kodi
Adds support for RAR archives to Kodi. This functionality was originally part of Kodi itself, but was removed in Kodi 18. See https://github.com/xbmc/xbmc/pull/11912 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4810
Diffstat (limited to 'media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild')
-rw-r--r--media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild b/media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild
new file mode 100644
index 000000000000..ccf6f48b14d7
--- /dev/null
+++ b/media-plugins/kodi-vfs-rar/kodi-vfs-rar-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="RAR VFS addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/vfs.rar"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/vfs.rar.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/vfs.rar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.rar-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-libs/kodi-platform-9999
+ =media-tv/kodi-9999
+ "