summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild')
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild
new file mode 100644
index 000000000000..43f8fdbe1ffc
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.9.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="502" # every bump, new version
+
+DESCRIPTION="VDR Plugin: support output on Graphical LCD "
+HOMEPAGE="http://projects.vdr-developer.org/projects/graphlcd"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="~x86 ~amd64"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6
+ >=app-misc/graphlcd-base-${PV}"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if ! getent group lp | grep -q vdr; then
+ echo
+ einfo "Add user 'vdr' to group 'lp' for full user access to parport device"
+ echo
+ elog "User vdr added to group lp"
+ gpasswd -a vdr lp
+ fi
+ if ! getent group usb | grep -q vdr; then
+ echo
+ einfo "Add user 'vdr' to group 'usb' for full user access to usb device"
+ echo
+ elog "User vdr added to group usb"
+ gpasswd -a vdr usb
+ fi
+}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i "s:/usr/local:/usr:" Makefile
+
+ sed -i "s:i18n.c:i18n.h:g" Makefile
+
+ sed -i "s:include \$(VDRDIR)/Make.global:-include \$(VDRDIR)/Make.global:" Makefile
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insopts -m0644 -ovdr -gvdr
+
+ insinto /usr/share/vdr/${VDRPLUGIN}/logos
+ doins -r ${VDRPLUGIN}/logos/*
+
+ insinto /usr/share/vdr/${VDRPLUGIN}/fonts
+ doins ${VDRPLUGIN}/fonts/*.fnt
+
+ for font in /usr/share/fonts/corefonts/*.ttf; do
+ elog ${font}
+ dosym ${font} /usr/share/vdr/graphlcd/fonts
+ done
+
+ insinto /etc/vdr/plugins/${VDRPLUGIN}
+ doins ${VDRPLUGIN}/logonames.alias.*
+ doins ${VDRPLUGIN}/fonts.conf.*
+
+ dosym /usr/share/vdr/${VDRPLUGIN}/fonts /etc/vdr/plugins/${VDRPLUGIN}/fonts
+ dosym /usr/share/vdr/${VDRPLUGIN}/logos /etc/vdr/plugins/${VDRPLUGIN}/logos
+ dosym /etc/graphlcd.conf /etc/vdr/plugins/${VDRPLUGIN}/graphlcd.conf
+
+ dosym /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias.1.3 /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias
+}
+
+pkg_preinst() {
+
+ if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] \
+ || [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
+
+ elog "Remove wrong DIR in /etc/vdr/plugins/graphlcd from prior install"
+ elog "Press CTRL+C to abbort"
+ epause
+ rmdir -R /etc/vdrplugins/graphlcd/{fonts,logos}
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "Add additional options in /etc/conf.d/vdr.graphlcd"
+ elog
+ elog "Please copy or link one of the supplied fonts.conf.*"
+ elog "files in /etc/vdr/plugins/graphlcd/ to"
+ elog "/etc/vdr/plugins/graphlcd/fonts.conf"
+}