summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 19:04:36 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 19:53:50 +0200
commit8fc9d684ba04ad85fb3029f399fc6cc57fcca357 (patch)
tree66b13827ff09f1c534898caf9aa308a13f845dcb /media-plugins/vdr-sleeptimer
parentmedia-plugins/vdr-launcher: tc-directly call fixed (diff)
downloadgentoo-8fc9d684ba04ad85fb3029f399fc6cc57fcca357.tar.gz
gentoo-8fc9d684ba04ad85fb3029f399fc6cc57fcca357.tar.bz2
gentoo-8fc9d684ba04ad85fb3029f399fc6cc57fcca357.zip
media-plugins/vdr-sleeptimer: tc-directly call fixed
Closes: https://bugs.gentoo.org/787497 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-sleeptimer')
-rw-r--r--media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6-r1.ebuild b/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6-r1.ebuild
new file mode 100644
index 000000000000..e209261840c6
--- /dev/null
+++ b/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Sleeptimer"
+HOMEPAGE="http://linvdr.org/download/vdr-sleeptimer"
+SRC_URI="http://linvdr.org/download/vdr-sleeptimer/${VDRPLUGIN}-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.6"
+
+PATCHES=( "${FILESDIR}/${P}-includes.diff" )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i sleeptimer.c -e "s:RegisterI18n://RegisterI18n:"
+
+ # 787497
+ sed -e "s:MAKEDEP = g++:MAKEDEP = \$(CXX):" -i Makefile
+}