summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-06-16 02:01:57 +0300
committerMart Raudsepp <leio@gentoo.org>2018-06-16 21:26:43 +0300
commita6d6f182fb2bd1682cd044bc236176ae444055e9 (patch)
treefb9347c90f9a1428799690687a69e2308b3d8ece /media-plugins
parentmedia-plugins/gst-plugins-opencv: bump to 1.14.1 (diff)
downloadgentoo-a6d6f182fb2bd1682cd044bc236176ae444055e9.tar.gz
gentoo-a6d6f182fb2bd1682cd044bc236176ae444055e9.tar.bz2
gentoo-a6d6f182fb2bd1682cd044bc236176ae444055e9.zip
media-plugins/gst-plugins-gtk: GStreamer video sink rendering on a GtkWidget
This was previously part of gst-plugins-bad via USE=gtk, but has been promoted to gst-plugins-good upstream and the new version is packaged properly as a split package, which also nicely keeps away the opengl flags sync mess from gst-plugins-good main package (very few packages use gtksink to date). Due to the code being part of gst-plugins-bad before, its KEYWORDS is copied for faster migration of consumers away from gst-plugins-bad[gtk] to the new package. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest1
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.1.ebuild31
-rw-r--r--media-plugins/gst-plugins-gtk/metadata.xml20
3 files changed, 52 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
new file mode 100644
index 000000000000..d062a22bd847
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -0,0 +1 @@
+DIST gst-plugins-good-1.14.1.tar.xz 3776168 BLAKE2B 5b17ac49d5bae423ee887f1516ba8bfb542acb17e3f304f489dddbaa728761ee51a08e67bd10a9981f53b5b8424d8013d1723fcbbf6e06d34a39548868d34f85 SHA512 b52d3214f2d32f263637cb9f0838284483e15b8d20bf36d64c349e99b481095734a4dd2c2421176540dfe5129ecc1acc101b89cc898b4773f0f736e8e962b070
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.1.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.1.ebuild
new file mode 100644
index 000000000000..c4b5c5af5433
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-bad is build with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"
diff --git a/media-plugins/gst-plugins-gtk/metadata.xml b/media-plugins/gst-plugins-gtk/metadata.xml
new file mode 100644
index 000000000000..250adbda6112
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gstreamer@gentoo.org</email>
+ <name>GStreamer package maintainers</name>
+</maintainer>
+<use>
+ <flag name="egl">Enable EGL platform usage</flag>
+ <flag name="gles2">Enable gtkglsink OpenGL sink based on GLESv2 API</flag>
+ <flag name="opengl">Enable gtkglsink OpenGL sink based on desktop OpenGL API</flag>
+</use>
+<longdescription lang="en">
+ GStreamer plugin for rendering video into a GtkWidget.
+
+ Includes the following elements:
+ * gtksink - A video sink that renders to a GtkWidget
+ * gtkglsink - A video sink that renders to a GtkWidget using OpenGL (built only with USE=opengl or USE=gles2)
+</longdescription>
+</pkgmetadata>