summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-03-19 21:04:18 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-03-19 21:04:18 -0700
commit0f55733d98d40982224e9a596bf6c04737903142 (patch)
treefa7f4bebe780591864fba94d5168d8bd15376168 /media-sound/apulse/apulse-0.1.9.ebuild
parentnet-vpn/wireguard: bump (diff)
downloadgentoo-0f55733d98d40982224e9a596bf6c04737903142.tar.gz
gentoo-0f55733d98d40982224e9a596bf6c04737903142.tar.bz2
gentoo-0f55733d98d40982224e9a596bf6c04737903142.zip
media-sound/apulse: version bump, bug 613254
Gentoo-Bug: 613254 Gentoo-Bug-URL: https://bugs.gentoo.org/613254 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/apulse/apulse-0.1.9.ebuild')
-rw-r--r--media-sound/apulse/apulse-0.1.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/apulse/apulse-0.1.9.ebuild b/media-sound/apulse/apulse-0.1.9.ebuild
new file mode 100644
index 000000000000..692b9facae2f
--- /dev/null
+++ b/media-sound/apulse/apulse-0.1.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib cmake-multilib
+
+DESCRIPTION="PulseAudio emulation for ALSA"
+HOMEPAGE="https://github.com/i-rinat/apulse"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/glib:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}
+ !!media-plugins/alsa-plugins[pulseaudio]"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/apulse )
+
+src_prepare() {
+ # Ensure all relevant libdirs are added, to support all ABIs
+ DIRS=
+ _add_dir() { DIRS="${EPREFIX}/usr/$(get_libdir)/apulse${DIRS:+:${DIRS}}"; }
+ multilib_foreach_abi _add_dir
+ sed -e "s#@@DIRS@@#${DIRS}#g" "${FILESDIR}"/apulse > "${T}"/apulse
+}
+
+multilib_src_configure() {
+ local mycmakeargs="-DAPULSEPATH=${EPREFIX}/usr/$(get_libdir)/apulse"
+ cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+ cmake-utils_src_install
+ einstalldocs
+ dobin "${T}"/apulse
+}