summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-01-20 22:25:40 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-01-20 23:15:48 +0100
commit75e46d7319ae344ddd180417ff380bcda495d9a8 (patch)
tree8face615fc9004e48a3dec6d75048edd588675ea /media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch
parentmedia-libs/portsmf: new package, add 239 (diff)
downloadgentoo-75e46d7319ae344ddd180417ff380bcda495d9a8.tar.gz
gentoo-75e46d7319ae344ddd180417ff380bcda495d9a8.tar.bz2
gentoo-75e46d7319ae344ddd180417ff380bcda495d9a8.zip
media-sound/audacity: add 3.2.3
This update also links against system portaudio. Keywords dropped to ~amd64 due to media-libs/portsmf. Closes: https://bugs.gentoo.org/777366 Closes: https://bugs.gentoo.org/822978 Closes: https://github.com/gentoo/gentoo/pull/28715 Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch')
-rw-r--r--media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch b/media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch
new file mode 100644
index 000000000000..53ac8edc33fb
--- /dev/null
+++ b/media-sound/audacity/files/audacity-3.2.3-allow-overriding-alsa-jack.patch
@@ -0,0 +1,48 @@
+From e46dbcb9763f4367705c66009703f15ff0ff5558 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Sat, 17 Dec 2022 21:13:56 +0100
+Subject: [PATCH] portmixer: Allow overriding PA_HAS_{ALSA,JACK}
+
+Not included for OSS as OSS is always included AFAICT.
+---
+ CMakeLists.txt | 3 +++
+ lib-src/portmixer/CMakeLists.txt | 9 ++++++---
+ 2 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 42e765691..c18a939e6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -624,6 +624,9 @@ cmd_option( ${_OPT}use_portmixer "Build PortMixer support into Audacity" On)
+ if( ${_OPT}use_portmixer )
+ set(USE_PORTMIXER Yes)
+ add_subdirectory( "lib-src/portmixer" )
++else()
++ # Suppress bogus warnings about unused variables
++ set (unusedIgnore "${PA_HAS_ALSA}${PA_HAS_JACK}${PA_HAS_OSS}")
+ endif()
+
+ cmd_option( ${_OPT}use_nyquist "Build Nyquist support into Audacity" On)
+diff --git a/lib-src/portmixer/CMakeLists.txt b/lib-src/portmixer/CMakeLists.txt
+index 65a384fa0..1ddc8ed50 100644
+--- a/lib-src/portmixer/CMakeLists.txt
++++ b/lib-src/portmixer/CMakeLists.txt
+@@ -8,9 +8,12 @@ if (UNIX AND NOT APPLE)
+ include(CheckIncludeFile)
+ set(CMAKE_REQUIRED_LIBRARIES PortAudio::PortAudio)
+
+- check_include_file( "pa_jack.h" PA_HAS_JACK )
+-
+- check_include_file( "pa_linux_alsa.h" PA_HAS_ALSA )
++ if ( NOT DEFINED PA_HAS_JACK )
++ check_include_file( "pa_jack.h" PA_HAS_JACK )
++ endif()
++ if ( NOT DEFINED PA_HAS_ALSA )
++ check_include_file( "pa_linux_alsa.h" PA_HAS_ALSA )
++ endif()
+ if( PA_HAS_ALSA )
+ find_package( ALSA REQUIRED QUIET )
+ endif()
+--
+2.39.0
+