summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-19 00:37:58 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-11 22:49:17 +0200
commitaeb045d44b3343ffcd5105982256983e6f14cc5a (patch)
tree0d9b2f1e38ea538b0420d33a9bffce2db801c91c /media-sound/denemo/files
parentdev-util/meson: drop test-llvm patch in the live ebuild (diff)
downloadgentoo-aeb045d44b3343ffcd5105982256983e6f14cc5a.tar.gz
gentoo-aeb045d44b3343ffcd5105982256983e6f14cc5a.tar.bz2
gentoo-aeb045d44b3343ffcd5105982256983e6f14cc5a.zip
media-sound/denemo: re-add package
* remove optional usage of guile-1, package now only supports guile-2 * fix problem with portaudio if use flag is not set see https://bugs.gentoo.org/515888#c23 and https://savannah.gnu.org/bugs/?52741 with https://savannah.gnu.org/bugs/?53804 * add REQUIRED_USE dependency for evince on gtk+:3 Suggested-by: Nikita Zlobin <nick87720z@gmail.com> Closes: https://bugs.gentoo.org/667164 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9908
Diffstat (limited to 'media-sound/denemo/files')
-rw-r--r--media-sound/denemo/files/denemo-2.2.0-find-guile-2.2.patch60
-rw-r--r--media-sound/denemo/files/denemo-2.2.0-no-portaudio-fix.patch29
2 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/denemo/files/denemo-2.2.0-find-guile-2.2.patch b/media-sound/denemo/files/denemo-2.2.0-find-guile-2.2.patch
new file mode 100644
index 000000000000..d69edb0173d5
--- /dev/null
+++ b/media-sound/denemo/files/denemo-2.2.0-find-guile-2.2.patch
@@ -0,0 +1,60 @@
+diff --git a/configure.ac b/configure.ac
+index 4bb3afa..9c146ad 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,10 @@ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_YACC
+ AM_PROG_LEX
++GUILE_PKG
+ GUILE_FLAGS
++CFLAGS="$CFLAGS $GUILE_CFLAGS"
++LIBS="$LIBS $GUILE_LIBS"
+
+ AC_PROG_LIBTOOL
+
+@@ -40,44 +43,6 @@ AS_COMPILER_FLAG([-fdiagnostics-color=auto],
+
+ AM_CONDITIONAL(ENABLE_GLIB_TEST, [test "x$enable_glibtest" = "xyes"])
+
+-AC_ARG_ENABLE(
+- guile_1_8,
+- AS_HELP_STRING([--enable-guile_1_8], [use GUILE_1_8 @<:@default=no@:>@]),
+- [
+- if test "x$enableval" != "xno"; then
+- useguile_1_8=yes
+- PKG_CHECK_MODULES(GUILE_1_8, guile-1.8 >= 1.8)
+- LIBS="$LIBS $GUILE_1_8_LIBS"
+- CFLAGS="$CFLAGS $GUILE_1_8_CFLAGS"
+- fi
+- ], [ useguile_1_8=no ])
+-
+-AC_ARG_ENABLE(
+- guile_2_0,
+- AS_HELP_STRING([--enable-guile_2_0], [use GUILE_2_0 @<:@default=no@:>@]),
+- [
+- if test "x$enableval" != "xno"; then
+- useguile_2_0=yes
+- PKG_CHECK_MODULES([GUILE_2], [guile-2.0])
+- LIBS="$LIBS $GUILE_2_LIBS"
+- CFLAGS="$CFLAGS $GUILE_2_CFLAGS"
+- fi
+- ], [ useguile_2_0=no ])
+-
+-if [test "x$useguile_1_8" = "xno"] && [test "x$useguile_2_0" = "xno"]; then
+- PKG_CHECK_MODULES([GUILE_2], [guile-2.0], useguile_2_0=yes, useguile_2_0=no)
+- LIBS="$LIBS $GUILE_2_LIBS"
+- CFLAGS="$CFLAGS $GUILE_2_CFLAGS"
+- if test "x$useguile_2_0" = "xno"; then
+- PKG_CHECK_MODULES(GUILE_1_8, guile-1.8 >= 1.8)
+- LIBS="$LIBS $GUILE_1_8_LIBS"
+- CFLAGS="$CFLAGS $GUILE_1_8_CFLAGS"
+- useguile_1_8=yes
+- else
+- useguile_2_0=yes
+- fi
+-fi
+-
+ PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.30])
+ CFLAGS="$CFLAGS $GLIB_CFLAGS"
+ LIBS="$LIBS $GLIB_LIBS"
diff --git a/media-sound/denemo/files/denemo-2.2.0-no-portaudio-fix.patch b/media-sound/denemo/files/denemo-2.2.0-no-portaudio-fix.patch
new file mode 100644
index 000000000000..a4aa60909de2
--- /dev/null
+++ b/media-sound/denemo/files/denemo-2.2.0-no-portaudio-fix.patch
@@ -0,0 +1,29 @@
+From 2e3c3b974e3e27873841c0ad9a05537a682e85f5 Mon Sep 17 00:00:00 2001
+From: Richard Shann <richard@rshann.plus.com>
+Date: Sat, 30 Dec 2017 15:32:35 +0000
+Subject: [PATCH 1/2] Fix bug #52741: Can't build with --disable-portaudio
+
+---
+src/audio/midi.c | 7 +++++++
+1 file changed, 7 insertions(+)
+
+diff --git a/src/audio/midi.c b/src/audio/midi.c
+index 55683cfe3..71c5df2cd 100644
+--- a/src/audio/midi.c
++++ b/src/audio/midi.c
+@@ -29,6 +29,13 @@
+
+ #define SHAVING (0.01) //seconds to shave off a note start time to ensure stopping before noteon is sent, and starting with noteon first note may depend of speed of machine??? FIXME
+
++#ifndef _HAVE_PORTAUDIO_
++gdouble get_playback_speed (void)
++{
++ return 1.0;
++}
++void set_playback_speed (double speed) {}
++#endif
+
+ static volatile gboolean playing = FALSE;
+
+--
+2.11.0