summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-30 11:55:12 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-30 11:55:12 +0200
commitfed9221df2b6c76fd192011ca900182d54a5c032 (patch)
tree9b3d97f2fd8a51d1856693fe86fbef8609e69045 /media-sound/gpodder
parentdev-python/mygpoclient: added py3_{8,9} (diff)
downloadgentoo-fed9221df2b6c76fd192011ca900182d54a5c032.tar.gz
gentoo-fed9221df2b6c76fd192011ca900182d54a5c032.tar.bz2
gentoo-fed9221df2b6c76fd192011ca900182d54a5c032.zip
media-sound/gpodder: bump to 3.10.16
1) eapi7 2) added py3_{8,9} 3) switched to xdg 4) dropped dev-python/isort Closes: https://bugs.gentoo.org/727686 Closes: https://bugs.gentoo.org/713064 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/gpodder')
-rw-r--r--media-sound/gpodder/Manifest1
-rw-r--r--media-sound/gpodder/gpodder-3.10.16.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index 0b8299d07f9d..3a24904a8723 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1 +1,2 @@
+DIST gpodder-3.10.16.tar.gz 1058386 BLAKE2B d73bc8a9d9d2cfe642a6c1e7ae3e7811e05db8c1ebf566904e669a5f9d029c6bce73599da737d25f42c4740d23537b1c414e7a23cf15076394fb714a2f33c79c SHA512 ce9525864e5a640dd82fb535021d63e1d1ddeb7785774b00c668ff86a279a45e075ab7488120ec93d1a07a0a943daa0abb786f822d74866e0fd8c6713d7f8531
DIST gpodder-3.10.5.tar.gz 1000492 BLAKE2B d3c1381fa613e018c79995a5b5d95958096dab49d4b4d9012e8741efe754f7f9db82e7fc46527e1fb837ce8fbfd3c14d58f8af64f96e51c5750b56402767ddca SHA512 056375d7a21f64e691bd62676d575dfaa8a32e715dc4f7ddf7b0c1cb9e99f07cef5972de812765874afd5a8e8adf220eb7b969afcc8dea1e2e3a76be8886c9cc
diff --git a/media-sound/gpodder/gpodder-3.10.16.ebuild b/media-sound/gpodder/gpodder-3.10.16.ebuild
new file mode 100644
index 000000000000..039b8dc0e28c
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.10.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="https://gpodder.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus bluetooth kernel_linux mtp test"
+RESTRICT="!test? ( test )"
+
+# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_MULTI_USEDEP}] and
+# ipod? ( media-libs/libgpod[python,${PYTHON_MULTI_USEDEP}] ) once they
+# support python3
+COMMON_DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/podcastparser-0.6.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/mygpoclient-1.8[${PYTHON_MULTI_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] )
+ ')
+ bluetooth? ( net-wireless/bluez )
+ mtp? ( >=media-libs/libmtp-1.0.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/iproute2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ dev-python/minimock
+ dev-python/coverage
+ )
+"
+
+src_install() {
+ emake PYTHON=python3 DESTDIR="${D}" install
+ distutils-r1_src_install
+}
+
+src_test() {
+ emake releasetest
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to use Youtube-dl extension, you need"
+ elog "to emerge net-misc/youtube-dl."
+ elog
+}