summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-22 10:33:13 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-22 10:33:13 +0200
commit63e58fc53a784c5af3d535781620f893bd7ddbcf (patch)
tree2cb3e07640a076d6675563e732b6c9291f6870a6 /media-sound/mp3check/mp3check-0.8.7.ebuild
parentmedia-sound/mp3check: Remove old (diff)
downloadgentoo-63e58fc53a784c5af3d535781620f893bd7ddbcf.tar.gz
gentoo-63e58fc53a784c5af3d535781620f893bd7ddbcf.tar.bz2
gentoo-63e58fc53a784c5af3d535781620f893bd7ddbcf.zip
media-sound/mp3check: Fix building against GCC 9
Closes: https://bugs.gentoo.org/685880 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/mp3check/mp3check-0.8.7.ebuild')
-rw-r--r--media-sound/mp3check/mp3check-0.8.7.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/media-sound/mp3check/mp3check-0.8.7.ebuild b/media-sound/mp3check/mp3check-0.8.7.ebuild
index ee78058978c7..97e7d314e0c2 100644
--- a/media-sound/mp3check/mp3check-0.8.7.ebuild
+++ b/media-sound/mp3check/mp3check-0.8.7.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
@@ -11,20 +12,18 @@ SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-src_prepare() {
- sed -i -e '/^WARN/s:-g::' Makefile || die
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.7-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-0.8.7-fix-c++14-operator-delete.patch
+)
src_configure() {
# tfiletools.h:59:50: warning: dereferencing type-punned pointer will break
# strict-aliasing rules [-Wstrict-aliasing]
append-cxxflags -fno-strict-aliasing
-}
-src_compile() {
- emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+ tc-export CXX
}
src_install() {