summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-06-24 12:09:25 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-06-24 12:09:25 +0100
commit846093f1c6627b30850e6f9ce280a7325df3653c (patch)
tree5dacc61ccef237a55fefc96dbeb2b4d710765f63 /media-sound/mpd-ynca
parentdev-python/rarfile: enable py3.12, fix pypy3 tests, PEP517 (diff)
downloadgentoo-846093f1c6627b30850e6f9ce280a7325df3653c.tar.gz
gentoo-846093f1c6627b30850e6f9ce280a7325df3653c.tar.bz2
gentoo-846093f1c6627b30850e6f9ce280a7325df3653c.zip
media-sound/mpd-ynca: New package
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-sound/mpd-ynca')
-rw-r--r--media-sound/mpd-ynca/Manifest1
-rw-r--r--media-sound/mpd-ynca/files/mpd-ynca.confd7
-rw-r--r--media-sound/mpd-ynca/files/mpd-ynca.initd17
-rw-r--r--media-sound/mpd-ynca/metadata.xml11
-rw-r--r--media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild33
5 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/mpd-ynca/Manifest b/media-sound/mpd-ynca/Manifest
new file mode 100644
index 000000000000..55eb77127b52
--- /dev/null
+++ b/media-sound/mpd-ynca/Manifest
@@ -0,0 +1 @@
+DIST mpd-ynca-0.1.0.tar.gz 12092 BLAKE2B b8b8fbd5323e8793631b3a1e6a0ead9f742a4a7b02ac254ab7617da24ff231c85ea70da3aed5026f985399c6051af074d14e022b5109a8083eb0a6b21a102dcd SHA512 752da6527d6989a30ecf754f054f2d0e1958cc68926197456fb5ed7431a8630d29a702b3865422b34cadfb8f49f9f8fbf393628b91748d301b7198bf64eb28d4
diff --git a/media-sound/mpd-ynca/files/mpd-ynca.confd b/media-sound/mpd-ynca/files/mpd-ynca.confd
new file mode 100644
index 000000000000..a042a82ceed0
--- /dev/null
+++ b/media-sound/mpd-ynca/files/mpd-ynca.confd
@@ -0,0 +1,7 @@
+# MPD client connection settings. You don't need to set these if using the mpd
+# service locally. See https://mpd.readthedocs.io/en/latest/client.html for
+# details.
+
+# MPD_HOST=localhost
+# MPD_PORT=6600
+# MPD_TIMEOUT=30
diff --git a/media-sound/mpd-ynca/files/mpd-ynca.initd b/media-sound/mpd-ynca/files/mpd-ynca.initd
new file mode 100644
index 000000000000..d18e3eeaec51
--- /dev/null
+++ b/media-sound/mpd-ynca/files/mpd-ynca.initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+export \
+ MPD_HOST \
+ MPD_PORT \
+ MPD_TIMEOUT
+
+pidfile="/run/${RC_SVCNAME}.pid"
+command="/usr/bin/mpd-ynca"
+command_user="mpd"
+command_background="yes"
+
+depend() {
+ after mpd
+}
diff --git a/media-sound/mpd-ynca/metadata.xml b/media-sound/mpd-ynca/metadata.xml
new file mode 100644
index 000000000000..1ce0e8c683b6
--- /dev/null
+++ b/media-sound/mpd-ynca/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chewi/mpd-ynca</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild b/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
new file mode 100644
index 000000000000..5493bd5a1c4c
--- /dev/null
+++ b/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="MPD client to control Yamaha AV receivers with YNCA (network control) support"
+HOMEPAGE="https://github.com/chewi/mpd-ynca"
+SRC_URI="https://github.com/chewi/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ acct-user/mpd
+ dev-libs/boost:=
+ media-libs/libmpdclient
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}