summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-17 12:11:10 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-17 12:11:10 +0200
commitf91f7821e45d9e09b1098528d9ca086c39b5f6a2 (patch)
tree17563b45ae47d7bf1e7f0cb37b1aa198d353465a /media-sound/poc/files
parentmedia-sound/picoxine: Port to EAPI 7 (diff)
downloadgentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.tar.gz
gentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.tar.bz2
gentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.zip
media-sound/poc: Port to EAPI 7
Bug: https://bugs.gentoo.org/697272 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/poc/files')
-rw-r--r--media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch4
-rw-r--r--media-sound/poc/files/poc-0.4.1-file-perms.patch4
-rw-r--r--media-sound/poc/files/poc-0.4.1-fix-build-system.patch30
3 files changed, 34 insertions, 4 deletions
diff --git a/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch b/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch
index f0957a1ca292..757a85faddb6 100644
--- a/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch
+++ b/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch
@@ -1,7 +1,7 @@
sync prototypes between the header and source
---- fec-pkt.c
-+++ fec-pkt.c
+--- a/fec-pkt.c
++++ b/fec-pkt.c
@@ -68,3 +68,3 @@
**/
-int fec_pkt_read(fec_pkt_t *pkt, int fd) {
diff --git a/media-sound/poc/files/poc-0.4.1-file-perms.patch b/media-sound/poc/files/poc-0.4.1-file-perms.patch
index ee23d90ab82b..71360341f0cf 100644
--- a/media-sound/poc/files/poc-0.4.1-file-perms.patch
+++ b/media-sound/poc/files/poc-0.4.1-file-perms.patch
@@ -1,7 +1,7 @@
Creating mp3 files with u+x attributes is just silly
---- file.c
-+++ file.c
+--- a/file.c
++++ b/file.c
@@ -136,3 +136,3 @@
file->fd = open(filename, O_WRONLY | O_CREAT | O_TRUNC,
- S_IRWXU | S_IRGRP | S_IROTH);
diff --git a/media-sound/poc/files/poc-0.4.1-fix-build-system.patch b/media-sound/poc/files/poc-0.4.1-fix-build-system.patch
new file mode 100644
index 000000000000..01a58084633c
--- /dev/null
+++ b/media-sound/poc/files/poc-0.4.1-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ #
+ # 2005 bl0rg.net
+
+-CFLAGS += -Wall -O2
++CFLAGS += -Wall
+
+ # Uncomment these flags to add id3 support to mp3cue and mp3cut
+ #CFLAGS += -DWITH_ID3TAG
+@@ -352,8 +352,9 @@
+
+ USER ?= root
+ GROUP ?= root
+-PREFIX:= /usr/local
++PREFIX:= /usr
+ install: install-man
++ install -d -g root -o root $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3cue $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3cut $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3length $(DESTDIR)/$(PREFIX)/bin
+@@ -367,6 +368,7 @@
+ install -g root -o root -m 0755 pogg-http $(DESTDIR)/$(PREFIX)/bin
+
+ install-man:
++ install -d -g root -o root $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3cue.1 $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3cut.1 $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3length.1 $(DESTDIR)/$(PREFIX)/share/man/man1