summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild')
-rw-r--r--media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild b/media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild
new file mode 100644
index 000000000000..ca4ed9b69e94
--- /dev/null
+++ b/media-sound/tapestrea/tapestrea-0.1.0.5-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Techniques + Paradigms for Expressive Synthesis, Transformation, Rendering of Environmental Audio"
+HOMEPAGE="http://taps.cs.princeton.edu/"
+SRC_URI="http://taps.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa doc jack oss"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit:0 )
+ alsa? ( >=media-libs/alsa-lib-0.9:0 )
+ media-libs/libsndfile:0
+ media-libs/freeglut:0
+ virtual/opengl:0
+ virtual/glu:0
+ x11-libs/gtk+:2"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison:0
+ sys-devel/flex:0"
+
+pkg_setup() {
+ if ! use alsa && ! use jack && ! use oss; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set at least one audio engine type"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+
+ # Respect LDFLAGS/CC
+ for bend in alsa jack oss; do
+ sed -i -e "s:gcc -o:\$(CC) \$(LDFLAGS) -o :" \
+ -e "s:-O3 -c:\$(CFLAGS) -c:" \
+ -e "s:make -C:\$(MAKE) -C :" \
+ "${S}/src/makefile.${bend}" || die
+ done
+
+ # Avoid "make jobserver unavailable" warning
+ sed -i -e "s:-make:\$(MAKE):g" \
+ "${S}/src/makefile" || die
+
+ sed -i -e "s:-make:\$(MAKE):g" \
+ "${S}/scripting/chuck-1.2.1.2/src/makefile" || die
+
+ epatch "${FILESDIR}"/${PF}-underlinking-alsa-pthread.patch
+}
+
+compile_backend() {
+ backend=$1
+ einfo "Compiling against ${backend}"
+
+ cd "${S}/scripting/chuck-1.2.1.2/src"
+ emake -f "makefile.${backend}" \
+ CC=$(tc-getCC) CXX=$(tc-getCXX) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+ cd "${S}/src"
+ emake -f "makefile.${backend}" \
+ CC=$(tc-getCC) CXX=$(tc-getCXX) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+ mv taps{,-${backend}} || die
+ emake -f makefile clean
+ cd "${S}/scripting/chuck-1.2.1.2/src"
+ emake -f makefile clean
+}
+
+src_compile() {
+ # When compiled with athlon or athlon-xp flags
+ # chuck crashes on removing a shred with a double free or corruption,
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ use jack && compile_backend jack
+ use alsa && compile_backend alsa
+ use oss && compile_backend oss
+}
+
+src_install() {
+ use jack && dobin src/taps-jack
+ use alsa && dobin src/taps-alsa
+ use oss && dobin src/taps-oss
+
+ dodoc AUTHORS BUGS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
+
+ if use doc ; then
+ for tapedir in `find examples/* -type d -maxdepth 0`; do
+ docinto $tapedir
+ dodoc `find $tapedir/* -type f -maxdepth 0`
+ for tapedir2 in `find $tapedir/* -type d -maxdepth 0`; do
+ docinto $tapedir2
+ dodoc `find $tapedir2/* -type f -maxdepth 0`
+ done
+ done
+ docinto doc
+ dodoc doc/*
+ fi
+}