summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-26 23:15:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-27 10:03:16 +0100
commit0cc8440ab828a2a29ba2d92dcb3ef6327b3615dd (patch)
treeb07854afb88bdbc25b64806342b89269b8a5e069 /media-sound/tomahawk
parentnet-dns/libidn: Prevent autotools updates (bug #638952 by skobk.in). (diff)
downloadgentoo-0cc8440ab828a2a29ba2d92dcb3ef6327b3615dd.tar.gz
gentoo-0cc8440ab828a2a29ba2d92dcb3ef6327b3615dd.tar.bz2
gentoo-0cc8440ab828a2a29ba2d92dcb3ef6327b3615dd.zip
media-sound/tomahawk: Add 0.9.0_pre20170808 snapshot
Fixes build with >=libvlc-3.0 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/Manifest3
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild74
2 files changed, 76 insertions, 1 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index c02148b54a2b..9a77cda1e424 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1 +1,2 @@
-DIST tomahawk-0.9.0_pre20161029.tar.xz 7945264 SHA256 de4005fd68dfb11380419829e009f19b901c4b14ccec6dd63400b21612886271 SHA512 fcfe810f167de936ed5457b3f30d7e17ef5708389800c6be85a1f867fc75a6973fcc04181719910c127dcc226619bd7ea31e0273b981f84c8122a2e1709fbcf9 WHIRLPOOL b914df1f2a26cc18af021ef6fce5511b2a103d7243340bcaec3d0c98fa90fc2fcda32cabc8022c2106d9bd9dffa777765e17433dc268f2c317537716c31928f6
+DIST tomahawk-0.9.0_pre20161029.tar.xz 7945264 BLAKE2B 8d12eaaf055da7dfe0dc4ff3e07c2be824983ca160d8ccd592ab611a8df09cead0d334e2ca3113c1bc34dea85c61edcf1bdeb6208316f1c372caf08bc04243e1 SHA512 fcfe810f167de936ed5457b3f30d7e17ef5708389800c6be85a1f867fc75a6973fcc04181719910c127dcc226619bd7ea31e0273b981f84c8122a2e1709fbcf9
+DIST tomahawk-0.9.0_pre20170808.tar.gz 9913232 BLAKE2B 5a7ebd9419fece090c0aec1f8f47bf35e1f0fbae5cd6a41803ac265e7310dadac61ba4f2e25b0d2fbbb0068cbb3f7098c1d330ac81e671be1028ed3b78d32560 SHA512 edaa4c1637ca460f838dfdd7ecc9d5dae0b66a8280deb8dc6140c673ecc76aa1055efbbac1e9b2937ec01d6dd657935b907cadceb2059f8e055305e872866c2b
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
new file mode 100644
index 000000000000..11fbc52732b3
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=00f602e10203b76fc28b4615868c567e6bd4ced4
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Multi-source social music player"
+HOMEPAGE="https://www.tomahawk-player.org/"
+SRC_URI="https://github.com/${PN}-player/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+hatchet telepathy xmpp"
+
+CDEPEND="
+ $(add_frameworks_dep attica)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ app-crypt/qca:2[qt5(+)]
+ dev-cpp/lucene++
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ >=media-libs/liblastfm-1.0.9-r1[qt5(+)]
+ >=media-libs/taglib-1.8.0
+ media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
+ >=net-libs/gnutls-3.2:=
+ x11-libs/libX11
+ hatchet? ( dev-cpp/websocketpp )
+ telepathy? ( >=net-libs/telepathy-qt-0.9.7-r1[qt5(+)] )
+ xmpp? ( >=net-libs/jreen-1.3.0[qt5(+)] )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep designer)
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${CDEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-liblastfm-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CRASHREPORTER=OFF
+ -DBUILD_TESTS=OFF
+ -DBUILD_TOOLS=OFF
+ -DBUILD_WITH_QT4=OFF
+ -DWITH_KDE4=OFF
+ -DBUILD_HATCHET=$(usex hatchet)
+ -DWITH_TelepathyQt=$(usex telepathy)
+ -DWITH_Jreen=$(usex xmpp)
+ )
+
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ kde5_src_configure
+}