summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-22 18:32:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-22 18:36:39 +0200
commit5c8fdbcaa0cf8908a8b8f526597425e8f12d9f30 (patch)
treed844f21933c969df917d7b4d8fcf7246122a516a /media-sound/xfmpc/xfmpc-0.3.1.ebuild
parentdev-python/symengine: Remove old (diff)
downloadgentoo-5c8fdbcaa0cf8908a8b8f526597425e8f12d9f30.tar.gz
gentoo-5c8fdbcaa0cf8908a8b8f526597425e8f12d9f30.tar.bz2
gentoo-5c8fdbcaa0cf8908a8b8f526597425e8f12d9f30.zip
media-sound/xfmpc: Bump to 0.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/xfmpc/xfmpc-0.3.1.ebuild')
-rw-r--r--media-sound/xfmpc/xfmpc-0.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/xfmpc/xfmpc-0.3.1.ebuild b/media-sound/xfmpc/xfmpc-0.3.1.ebuild
new file mode 100644
index 000000000000..69378a9435cf
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Music Player Daemon (MPD) client for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfmpc/start
+ https://gitlab.xfce.org/apps/xfmpc/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38.0:2=
+ >=media-libs/libmpd-0.15.0:=
+ >=x11-libs/gtk+-3.22.0:3=
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/libxfce4util-4.12.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}