summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/xmms2-scrobbler/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/xmms2-scrobbler/files')
-rw-r--r--media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ld-order.patch32
-rw-r--r--media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ldflags.patch19
-rw-r--r--media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-libs.patch19
3 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ld-order.patch b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ld-order.patch
new file mode 100644
index 000000000000..1ba5443a9264
--- /dev/null
+++ b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ld-order.patch
@@ -0,0 +1,32 @@
+commit 096ee717070bdde9c1adc29f02fcb537920daca9
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat Mar 3 20:24:21 2012 +0300
+
+ Makefile: set proper link order for libraries
+
+ '-Wl,--as-needed' enforces libraries to go in proper dependency order:
+
+ $ x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu `pkg-config xmms2-client --libs` `pkg-config libcurl --libs` src/xmms2-scrobbler.o src/list.o src/queue.o src/strbuf.o src/md5.o src/submission.o -o bin/xmms2-scrobbler
+ src/xmms2-scrobbler.o: In function `save_profile_submissions_queue':
+ xmms2-scrobbler.c:(.text+0x281): undefined reference to `xmmsc_userconfdir_get'
+ src/xmms2-scrobbler.o: In function `load_config':
+ xmms2-scrobbler.c:(.text+0x3e2): undefined reference to `xmmsc_userconfdir_get'
+ src/xmms2-scrobbler.o: In function `maybe_submit_to_profile':
+ xmms2-scrobbler.c:(.text+0x7e3): undefined reference to `xmmsc_medialib_get_info'
+ xmms2-scrobbler.c:(.text+0x7f7): undefined reference to `xmmsc_result_notifier_set'
+
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+diff --git a/Makefile b/Makefile
+index 7693bd2..4207cda 100644
+--- a/Makefile
++++ b/Makefile
+@@ -36,7 +36,7 @@ install: $(BINARY)
+ install -m 755 $(BINARY) $(DESTDIR)$(PREFIX)/bin
+
+ $(BINARY): $(OBJECTS) bin
+- $(QUIET_LINK)$(CC) $(OBJECTS) $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) -o $@ $(LIBS)
++ $(QUIET_LINK)$(CC) $(OBJECTS) -o $@ $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) $(LIBS)
+
+ src/%.o : src/%.c
+ $(QUIET_CC)$(CC) $(CFLAGS) $(XMMS_CFLAGS) $(CURL_CFLAGS) $(ENDIAN_CFLAGS) -o $@ -c $<
diff --git a/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ldflags.patch b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ldflags.patch
new file mode 100644
index 000000000000..a570548ed4e9
--- /dev/null
+++ b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-ldflags.patch
@@ -0,0 +1,19 @@
+commit 8b97319c1a03acecc21b5608516859daaf5bca75
+Author: James Le Cuirot <chewi@aura-online.co.uk>
+Date: Fri Mar 26 20:10:54 2010 +0100
+
+ Fixed the build if the --as-needed linker option is enabled.
+
+diff --git a/Makefile b/Makefile
+index dad3fcb..3331e30 100644
+--- a/Makefile
++++ b/Makefile
+@@ -35,7 +35,7 @@ install: $(BINARY)
+ install -m 755 $(BINARY) $(DESTDIR)$(PREFIX)/bin
+
+ $(BINARY): $(OBJECTS) bin
+- $(QUIET_LINK)$(CC) $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) $(OBJECTS) -o $@
++ $(QUIET_LINK)$(CC) $(OBJECTS) $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) -o $@
+
+ src/%.o : src/%.c
+ $(QUIET_CC)$(CC) $(CFLAGS) $(XMMS_CFLAGS) $(CURL_CFLAGS) $(ENDIAN_CFLAGS) -o $@ -c $<
diff --git a/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-libs.patch b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-libs.patch
new file mode 100644
index 000000000000..959f1232e6d5
--- /dev/null
+++ b/media-sound/xmms2-scrobbler/files/xmms2-scrobbler-0.4.0-libs.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index 3331e30..7693bd2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,5 @@
+ CFLAGS += -std=gnu99 -Wall -Wwrite-strings -pthread
++LIBS = -lrt -lpthread
+ ENDIAN_CFLAGS=
+ PREFIX ?= /usr/local
+
+@@ -35,7 +36,7 @@ install: $(BINARY)
+ install -m 755 $(BINARY) $(DESTDIR)$(PREFIX)/bin
+
+ $(BINARY): $(OBJECTS) bin
+- $(QUIET_LINK)$(CC) $(OBJECTS) $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) -o $@
++ $(QUIET_LINK)$(CC) $(OBJECTS) $(LDFLAGS) $(XMMS_LDFLAGS) $(CURL_LDFLAGS) -o $@ $(LIBS)
+
+ src/%.o : src/%.c
+ $(QUIET_CC)$(CC) $(CFLAGS) $(XMMS_CFLAGS) $(CURL_CFLAGS) $(ENDIAN_CFLAGS) -o $@ -c $<