summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-06-15 11:40:57 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-06-15 11:40:57 +0200
commita357c9bbb53ff112340d84359b1cd062750603db (patch)
treed178d4c2d055a1d96146a5bda2d485b3257be922 /media-sound
parentnet-analyzer/tcpreplay: Update SRC_URI (diff)
downloadgentoo-a357c9bbb53ff112340d84359b1cd062750603db.tar.gz
gentoo-a357c9bbb53ff112340d84359b1cd062750603db.tar.bz2
gentoo-a357c9bbb53ff112340d84359b1cd062750603db.zip
media-sound/patchage: fixed compilation and dep in 1.0.2
Closes: https://bugs.gentoo.org/728178 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/patchage/files/patchage-1.0.2-string.patch11
-rw-r--r--media-sound/patchage/patchage-1.0.2.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/media-sound/patchage/files/patchage-1.0.2-string.patch b/media-sound/patchage/files/patchage-1.0.2-string.patch
new file mode 100644
index 000000000000..fe63be714d8a
--- /dev/null
+++ b/media-sound/patchage/files/patchage-1.0.2-string.patch
@@ -0,0 +1,11 @@
+--- a/src/Patchage.cpp
++++ b/src/Patchage.cpp
+@@ -743,7 +743,7 @@
+ for (int c = 0; cmd[c].uuid; ++c) {
+ std::string command = cmd[c].command;
+ const size_t index = command.find(var);
+- if (index != string::npos) {
++ if (index != std::string::npos) {
+ command.replace(index, var.length(), cmd[c].client_name);
+ }
+
diff --git a/media-sound/patchage/patchage-1.0.2.ebuild b/media-sound/patchage/patchage-1.0.2.ebuild
index d936e4293435..7e4f4bd5b7e5 100644
--- a/media-sound/patchage/patchage-1.0.2.ebuild
+++ b/media-sound/patchage/patchage-1.0.2.ebuild
@@ -19,7 +19,7 @@ RDEPEND=">=dev-cpp/glibmm-2.14:2
>=dev-cpp/gtkmm-2.11.12:2.4
>=dev-cpp/libglademm-2.6.0:2.4
dev-cpp/libgnomecanvasmm:2.6
- >=media-libs/ganv-1.4.0
+ >=media-libs/ganv-1.5.2
virtual/jack
alsa? ( media-libs/alsa-lib )
jack-dbus? ( dev-libs/dbus-glib
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README.md )
+#PATCHES=(
+# "${FILESDIR}/${P}-string.patch"
+#)
+
src_configure() {
waf-utils_src_configure \
$(use debug && echo "--debug") \