summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-11-24 20:46:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-11-24 20:46:47 +0000
commitb52fc1b52bdf37dbb9a97af4c83737fd03f213d0 (patch)
tree9f14cd169e584e46fd6a0f42acb7daff62b12588 /media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild
parentnet-print/hplip-plugin: Version bump to 3.19.11 (diff)
downloadgentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.tar.gz
gentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.tar.bz2
gentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.zip
media-tv/dtv-scan-tables: Version bump to 0_p20190922
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild')
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild
new file mode 100644
index 000000000000..73d9b36229da
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="f07bde777d4d"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=media-tv/v4l-utils-1.4"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install install_v3
+ einstalldocs
+}